2

Roughly every hour, my MBP gets very hot, my fans go crazy, everything slows down, and when I look in Activity Monitor it tells me that softwareupdated is running at 100% CPU. It lasts about 2-3 minutes each time and then disappears.

I am running Yosemite 10.10.5 on an early 2011 MBP. I shut down every night and reboot in the morning.

What I have tried:

  1. I have done all of the updates available in the App Store.
  2. I have unchecked every box in the App Store settings regarding checking for updates (in fact, I have just unchecked every box).
  3. I have disabled check for updates in iTunes settings.
  4. I have force-quit softwareupdated in Activity Monitor. It comes back straight away to finish whatever mystery task it is performing.

Having looked at similar questions, this problem seems unusual. Most report that softwareupdated runs constantly at high CPU, instead of coming and going. The recommended trick to deal with this is to reboot, however that does nothing for my problem.

I am not computer literate enough to know how to determine precisely what app is launching this (or even if it is an app launching it). The only things I generally have running are Terminal, MATLAB 2016b, Safari, and iTunes. Sometimes Mail.

It's driving me mad; I am sure it can't be good for it to suddenly get so hot, so regularly. Moreover, I am worried that the only way to get it to stop is to upgrade to Sierra, but my MBP is pretty old and I am concerned about slow-down.

My questions:

  1. How can I find out why it is running?
  2. Are there any other apps, like iTunes, that have independent update checking?
  3. Is it possible that my settings regarding checking for updates are being overridden?

EDIT: I should perhaps say, this has been an ongoing problem for quite some time now. It is not something that has suddenly started - I am just using my Mac more than usual at the moment, and hence it is now becoming a real problem.

0

Hmm. Try opening up terminal, and at the prompt, enter the command:

$ softwareupdate -l && sudo softwareupdate -i -a

That will tell the system to show you which updates need to be done, then run software update and install all of the updates it found. See if it gives you any error messages; it may ask you to reboot right away, in which case do that. Run the same command again after the reboot and see if it still finds updates to install or if nothing shows up. If nothing shows up then it completed all the updates, and the problem hopefully goes away. If not, let us know.

  • Thank you for your quick response. When I run this command, my mac happily asserts that there are no available software updates. Yet softwareupdated continues to keep reappearing. Do you have any other ideas? I wonder, is it possible that it could be linked to a particular application? – Kino May 20 '17 at 13:29
  • @Kino I doubt it, because that process is Apple's update checker.. – Harv May 20 '17 at 19:04
  • I have had a look at the console after it has just happened. Is it possible that it is to do with the Google software update agent, or would that be named differently? There is an entry regarding Google software updates at the ~correct time, and MANY throughout the day. Many thanks again. – Kino May 20 '17 at 21:36
  • @Kino See this, maybe it'll help: apple.stackexchange.com/questions/170880/… – Harv May 21 '17 at 21:05
  • Thanks Harv. Actually I had already had a look through that, but it didn't really shed any light on the problem. However, I have now resolved this - it was caused by my VPN agent (GlobalProtect). Switching to Tunnelblick has fixed the issue. Many thanks for your help. (I would upvote, of course, but unfortunately I do not have enough rep!!) – Kino May 23 '17 at 15:12
0

Answering my own question - after an extremely laborious process of elimination, I discovered that the application causing softwareupdated to run so frequently was my VPN agent (GlobalProtect), which I use to connect to my university network when working from home.

GlobalProtect will initiate softwareupdated every time it connects, and periodically whilst connected. There is no option to disable this feature as an end user, even when using the most up-to-date version.

I have uninstalled GlobalProtect and switched to using Tunnelblick, which is also approved for use with my university. So far, so good!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .