1

I recently migrated my macbook 12" to a macbook pro (touchbar). I used the migration assistant to transfer a backup from the old mac to the new one. At first all was successful apart from a slight issue with the incompatible OS version between the two machines. (I had to update before migrating)

I am running Sierra(10.12.5 (16F73)) on the new machine. I am now facing a number of issues with the machine, I would guess its a permission thing. I think but cannot be certain that vmware fusion has something to do with the issue because it was the last program I tried to install from the old backup before seeing issues. (I had to kill the installation)

  • safari opens and appears to load a page, but just sits there - no matter what the url is. Chrome and Firefox work perfectly well and other programs do not have an issue getting an internet connection.
  • mac store updates do not work, when I click update on an app, I see: "We could not complete your update. Unknown error"

I noticed that the owner of my application (located at /Library/*) is as follows:

drwxr-xr-x@ 3 root wheel 102 30 Jun 2016 Safari.app

  1. Should root own these applications?
  2. How can I debug this issue with safari and the app store updates?
  3. Any thoughts what could cause behaviour like this?

So far, I have tried, neither worked:

  1. Repairing disk permissions using the 'first aid' tool in disk utility.
  2. Reinstall OS (restart, cmd+r, Reinstall OS)

Thanks

  • Create a temporary user account and see if the problem occurs in this account. Have you tried other browsers? – IconDaemon May 17 '17 at 17:39
  • only tried chrome and firefox, as mentioned above. will try a new user account now – user3939059 May 17 '17 at 17:45
  • creating a new user accounts solves the issue with safari. so i guess this is a user level permission issue? – user3939059 May 17 '17 at 17:49
  • Either that or a .plist file or files corruption problem. Have you cleared all the caches & cookies in Safari? Preferences > Privacy > Manage Website Data. This page can help with some of the finer details. – IconDaemon May 17 '17 at 17:56
  • thanks for your reply. interestingly when i try to remove all my cookies, they re-appear again - which is very odd. – user3939059 May 17 '17 at 20:06
0

Thank you @IconDaemon - you comment solved it.

Step 1: Follow this link and run the terminal command.

Step 2: Restart the Mac in safe mode.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .