3

Even though JRE 8 is installed on my MAC OS Yosemite 10.10.3,while running the Android present in tools in sdk - the error - " No Java Runtime present,requesting to install " gets displayed in terminal- how do i solve this issue?

I wanted to install Xamarin test recorder - after installing they asked me to install Android sdk SDK is downloaded in Library/Developer/Xamarin/android-sdk Now when I run Android present in tools folder - I get the error - No Java run time I've installed JRE 8 with get the verified java version from their site Can someone please help!!

6

You must install the full JDK, not just the JRE, to get Java support on macOS. For some reason the JRE just installs the browser plugins, not the full Java.

This is the current JDK download page.

1

You don't need to install the full JDK. I had the same issue and eventually solved it by placing the following JAVA_HOME export in ~/.bash_profile:

export JAVA_HOME=/Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin/Contents/Home

Hope this helps someone. I'm running Mac OS High Sierra.

0

This worked for me on macOS high sierra. Did not install JDK.

Go to terminal:

  1. vim .bash_profile
  2. Clear everything. Add export JAVA_HOME=/Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin/Contents/Home . Save and close it.
  3. source .bash_profile
  4. java -version

You should be able to see java version

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .