5

First apologies if this is not the best Stack Exchange site to ask this on, or this is "off topic", but I was directed here from Server Fault as it was "off-topic" for that site. I have asked this question over on Mac Rumors, but received zero responses at this time. Please feel free to redirect me to a more appropriate S.E. site if there is a more suitable one.

I have seen many threads over the net about iPhone7 WiFi connectivity issues, but none of the answers for theirs have fixed my issue.

Problem:

We have an issue at home where the two iPhone 7s often will not connect or if they do connect, wont hold a connection for very long (10 - 20 minutes).

We have multiple other devices, both Apple and non-Apple who connect fine and hold their connection. It is only the two iPhone 7s which are experiencing this issue. The iPhone 6, iPhone 5, iPad 2, iPad mini, iMac, two Android phones, one Android tablet and Windows laptop all connect without issue.

WiFi Infrastructure:

  • Sky Broadband SR102, connected to internet and working as Fibre broadband modem, DHCP server and WiFi access point and router
  • Sky Broadband SR102, connected to SR102 by LAN cable, DHCP disabled, working as WiFi access point and router
  • NetGear WNR2200, connected to SR102 by LAN cable, DHCP disabled, working as WiFi access point and router. Also has Guest account enabled.

All WiFi access points have the same SID broadcast, the same encryption type and same password. All three broadcast on different channels, which only overlap slightly according to “WiFi Analyser” application. All WiFi is 2.4GHz. No 5Ghz in house.

enter image description here

Often when the iPhone has no connection the IP address is well outside of the DHCP range. Often something like 169.254.xxx.xxx. I understand from other threads this is an IP address the iPhone assigns its self when it cannot get one from the DCHP server. Sometimes the IP address is just plain 0.0.0.0.

Solutions which have not worked for us are:

  • Disconnecting and reconnecting WiFi on iPhone7
  • Renewing the lease on the iPhone7
  • Restarting the iPhone7
  • Forgetting WiFi network and re-adding it on iPhone7
  • Restarting all of the routers
  • Allowing SR102 to dynamically assign all IP addresses
  • Giving all frequently active devices in house static IP addresses in the device access list on the SR102. The static IP addresses are based upon MAC address. The SR102 still hands out dynamic IP addresses to any other device.
  • Setting static IP addresses (to match those set on SR102) on iPhone7s
  • Resetting network settings on iPhone7
  • Turning Bluetooth off on iPhone7 (advice from forum posts - not practical and did not work)
  • Disconnect all IP6 DHCP on routers

We have also been to the Apple store and had twenty minutes with a genius, but after running a diagnostic tool on phone he was unable to offer anything other than what we had already tried except a full factory reset to new phone state, which is less than ideal for us.

I have seen posts around the net where other iPhone7 users having this issue can be sat next to partners with iPhone6, iPhone5, Android phones or iPads who can connect perfectly. It seems to be quite a common affliction to the iPhone7. Please can anyone offer any other advice? Thanks in advance.

migrated from superuser.com May 16 '17 at 19:16

This question came from our site for computer enthusiasts and power users.

  • I see no problem with the content. It seems to be perfectly relevant! – Rushat Rai Jun 1 '17 at 6:46
  • Have you tried to configure your Wifi on 5GHz channels ? – MOUSLEM BOUCHAMEKH May 19 '18 at 18:50
2

Comments from a former work colleague who read my problem:

yes you definitely have a weird issue there. The fact you get a 169.254.x.x address means that it is unable to get a lease from the router as you correctly said. Possible issues for this are: unable to reach the dhcp server, e.g. it's in a different VLAN, the lease addresses have all been issued, the dhcp server no longer works correctly. However we can rule most of them out by the information provided.

I would advise checking the scope to make sure it's nice and big e.g. /24 to give you 253 usable addresses. Another thing I have noticed in the past is that apple devices much prefer 5ghz networks and always try to connect to them. I don't think it will be long before they turn off the 2.4 spectrum altogether.

Another possibility is interference all Wi-Fi channels should be non overlapping to do this either set channel 1,6 or 11 depending on which one is less congested. Any slight overlapping gives the potential for interference. Other than that I don't really have any better ideas without getting any real information. It may be worth looking at the logs of the AP to see if the iPhone disassociates or whether the AP kicks it off.

IP Scope The scope of DHCP is very wide from 192.168.0.02 to 192.168.0.254 with around thirty of those IPs set statically by the SR102 router. So there should be plenty available for the router to give out. Plus the two iPhone7s have been given static IPs in the router based upon MAC address of the phone.

Channels My channels are a little close as they are set to auto in each access point so they look for the least congested channel. I may split 1,6,11 as suggested above.


EDIT: I did split channels to 1, 6 and 11, and although that seemed to work initially after a day it was all pretty much back to the "norm" with the two iPhone 7s not getting IP addresses from the router / APs.

2
+50

I've never heard of a router prioritizing devices but maybe they are running out of leases. Can you try to disconnect a bunch of devices & then see if you can replicate it again?

When I worked at AppleCare I did see a case where an odd character in a SSID caused connection issues - try making the SSID all numbers & letters only if they aren't already.

I'm also curious if this would happen with only one router plugged in. Maybe something is going wrong when they try to switch to a different router. If this ends up working I would try a separate name for each SSID, iPhones should still always try and connect to the one with the strongest signal.

  • Hi. The SIS is only letters and numbers already. We did try having seperate SID per router but although the android devices would move to the next strongest router signal the apple devices tended to stay connected to the same router even if the signal dropped to 1 bar or less and they were sat right next to the other router. – Dib Jun 1 '17 at 4:47
  • Will try disconnecting other devices when it next happens to see if the leases be running out. – Dib Jun 1 '17 at 4:48
  • Disconnecting another device either occasionally works, but not always, or was coincidental. – Dib Jun 8 '17 at 4:45
  • Can you replicate this with other networks, maybe a friends? I also still think that trying with only one router plugged in might be worth it - every router also counts towards the limited numbers of leases, and I believe that each one will also have their own limit on devices. I would also make sure that the firmware on each router is fully up to date if you haven't checked yet. – little tiny man Jun 8 '17 at 23:38
  • Hi firmware is old on all devices but is the most up to date available. The two iPhone7 devices are not mine but other family members so I can't really take them to a friend's house to try them. One of the iPhone7 connects fine at the local college wifi network but that may use an enterprise based mesh rather than just wifi repeaters dotted around. I'll try just the one router at some point but it's difficult to find time when other house hold members don't need the Internet for a few hours as the WiFi will not reach upstairs from the one router downstairs. – Dib Jun 9 '17 at 5:19
1

It seems as though it's an issue with your local network. You may want to take a look into your 2.4GHz settings, and change them to Apple's Specified 20 MHz bandwith.

2.4 GHz channel width

Channel width controls how large of a ”pipe” is available to transfer data. However, larger channels are more subject to interference and more likely to interfere with other devices. A 40 MHz channel is sometimes called a wide channel, and a 20 MHz channel is a narrow channel.

Set to: 20 MHz

Use 20 MHz channels in the 2.4 GHz band. Using 40 MHz channels in the 2.4 GHz band can cause performance and reliability issues with your network, especially in the presence of other Wi-Fi networks and other 2.4 GHz devices. A 40 MHz channel might also cause interference and issues with other devices that use this band, such as Bluetooth devices, cordless phones, and neighboring Wi-Fi networks. Routers that don't support 40 MHz channels in the 2.4 GHz band do support 20 MHz channels.

If you choose to use the 5GHz channel width, it is reccomended that you use the 20/40 MHz band.

5 GHz channel width

Channel width controls how large of a "pipe" is available to transfer data. Larger channels are more susceptible to interference, and more likely to interfere with other devices. Interference is less of an issue in the 5 GHz band than in the 2.4 GHz band. A 40 MHz channel is sometimes called a wide channel, and a 20 MHz channel is a narrow channel. Set to:

For 802.11n access points, set the 5GHz band to 20 MHz and 40 MHz.

For 802.11ac access points, set the 5GHz band to 20 MHz, 40 MHz, and 80 MHz.

For best performance and reliability, enable support for all channel widths. This allows devices to use the largest width they support, which results in optimal performance and compatibility. Not all client devices support 40 MHz channels, so don't enable 40 MHz-only mode. Devices that support only 20 MHz channels cant connect to a Wi-Fi router in 40 MHz-only mode. Similarly, don't enable 80 MHz-only mode, or only clients capable of 802.11ac will be able to connect. Routers that don't support 40 MHz or 80 MHz channels do support 20 MHz channels.


Source: https://support.apple.com/en-ca/HT202068

  • Hi Bret. Thanks for the advice. According to "Wifi Analyser" android app the three access points are all running on 22MHz. The only wifi network we have running 40MHz is not connected to by any of the iPhones. It is dedicated to two android devices and an XBox. – Dib May 16 '17 at 21:07
  • In addition none of the routers appear to have settings to switch between 20MHz and 40MHz anyway! – Dib May 16 '17 at 21:12
  • 1
    Are any of the Wi-Fi Routers trying to run on the same channel, if so, this could be the issue. – bret7600 May 16 '17 at 23:23
  • 1
    Hi Bret. As per post."All three broadcast on different channels, which only overlap slightly according to “WiFi Analyser” application. All WiFi is 2.4GHz." – Dib May 17 '17 at 5:07
  • Good call though, Bret – Dib May 17 '17 at 5:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .