In Notes app I have some notes stored: On My Mac

my share menu though only gives me the following choices:

share menu

when I click More...

more menu

AirDrop is selected and at the top!

Mail and Messages shows up, but no AirDrop.

How can I AirDrop my Notes from mac to iDevice?

edit: already fixed in macOS High Sierra.


It appears that you cannot share notes via Airdrop from a Mac.

I have checked four Macs (all running either El Capitan or Sierra) and in each case I find the exact same situation as you. More specifically, trying to share a note does not give me the option of using Airdrop and if I click on the More... option I also see AirDrop listed with a ticked checkmark (greyed out just like in your screenshot).

This is not something I had noticed previously as I haven't tried to share a Note from any of my Macs.

Now, I also checked whether this is a known issue and found this discussion on Apple's website. Although it was started in January 2015, you'll see that the most recent post was (at the time of writing this) just over a week ago.

I'm not entirely sure why sharing notes via AirDrop from a Mac isn't an option (although the fact that notes are all stored within the Notes app and can be synced via iCloud may be part of the reason).

I suggest you send feedback to Apple.

If you do need a way to share your notes via Airdrop, then there's a few workarounds online (including within the above-mentioned discussion). The one I like most is to do as follows:

  1. Within the Notes app, open the note you want to share
  2. Go to File > Export as PDF...
  3. Click Save
  4. Within Finder, navigate to the exported PDF
  5. Right-click on the file
  6. Select Share > AirDrop
| improve this answer | |
  • I'm wondering if it's because Notes are now synced across all devices with the same Apple ID? – fsb May 16 '17 at 16:49
  • Yeah, that's what I'm thinking too. Regardless, it's not consistent behaviour and is actually bad UX design. After all, if we can share a note to other users via Messages, etc, then why not via AirDrop? Just seems odd. – Monomeeth May 17 '17 at 2:03

In the notes app on your MacBook go to File > Share > Airdrop

I had the same issue as you, but found this way is simpler than the previous answer.

| improve this answer | |
  • I thin k this was more of a Sierra problem, already fixed in High Sierra. – Mo. Nov 27 '17 at 7:19

I ran into the same problem when changing macbook. I used the following workaround which uses iCloud only very briefly:

  • on the source Mac open iCloud preferences
  • enable iCloud for Notes on the "source Mac"
  • drag and drop all your notes from "On My Mac" to "iCloud"
  • enable iCloud for Notes on the "target Mac"
  • all your notes should appear on the target Mac in category iCloud
  • open Notes preferences, and select "Enable the On My Mac account"
  • drag all notes from the "iCloud" to "On My Mac"
  • go back to iCloud preferences and disable iCloud for Notes on both Macs


| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .