3

My Spotlight search behaves strange and I don't know how to fix it. Any Ideas?

When I want to open Numbers, I hit command space and start typing "number",

spotlight screenshot

but if I keep on typing the "s", essentially completing the app name Numbers, Spotlight does not know what to do anymore.

enter image description here

Does the index point into a wrong direction? If I search for a specific file it works.

I tried the solutions by Anil and Senseful here, but the problem does not change

UPDATE

After rebuilding the Spotlight library the problem shortly disappeared (one week). But it returned again. So maybe my question is not how to solve this problem but what is corrupting my Spotlight index?

Interestingly the Spotlight results look a bit different now and shows the App-Store Numbers version (which then automatically opens the local one).

enter image description here

  • thank you @user3439894 for reformatting, I was writing it up while my head was still unsettled. However, I think I should have amphasized a lot more what I already did instead of (just) mentioning the authors of those entries. – rul30 May 22 '17 at 19:55
  • Did either of these answers help you with your issue? If yes, please up-vote answers and accept answer as appropriate. – user3439894 May 29 '17 at 17:21
2

I would first do as suggested in Hefewe1zen's answer, rebuild the Spotlight index on your Mac.

If that doesn't fix the issue, then the next thing I'd try is rebuilding the Launch Services Database.

In Terminal:

/S*/L*/F*/C*/F*/L*/S*/lsregister -kill -r -domain local -domain system -domain user

I always use the short form of the command above, however here is the long form:

/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

There is no manual page for lsregister however, the following command outputs the internal help file:

/S*/L*/F*/C*/F*/L*/S*/lsregister --help

If you want to read more about rebuilding the Launch Services Database, Google is your friend!

If by chance neither of these suggested answers work, then I'd reinstall Numbers.

  • I am not totally sure when Spotlight worked again. In any case using the terminal commands from the other entry and than using this command solved the problem eventually. – rul30 Jun 2 '17 at 21:17
4

I would start by rebuilding the Spotlight index.

From: How to rebuild the Spotlight index on your Mac

  1. Choose Apple menu () > System Preferences, then click Spotlight.
  2. Click the Privacy tab.
  3. Drag the folder or disk that you want to index again to the list of locations that Spotlight is prevented from searching. Or click the Add (+) button and select the folder or disk to add.
    To add an item to the Privacy tab, you must have ownership permissions for that item. To learn about permissions, choose Help from the Finder menu bar, then search for “permissions.”
  4. From the same list of locations, select the folder or disk that you just added. Then click the Remove (–) button to remove it from the list.
  5. Quit System Preferences. Spotlight will reindex the contents of the folder or disk.

Or via Terminal:

sudo mdutil -i off /
sudo mdutil -i on /
sudo mdutil -E

See the man page for mdutil or type man mdutil in Terminal.

  • To whomever down-voted this answer, why!? IMO, its a valid step to take! (Even if it doesn't fix the issue!) +1 – user3439894 May 14 '17 at 15:54
  • Didn't down vote and I agree with @user3439894 ...though you should include the steps to rebuild the index in the answer because links to Apple do (and often) change making them stale. – Allan May 14 '17 at 15:56
  • @Allan, I agree with at least a minimum summarizing if to long, although in this case was short enough to just copy the steps and quoted it and where from. Also added man page link/info for mdutil however, that said he at least included the Terminal commands, so not quoting the Apple support article shouldn't be grounds to automatically down-vote in this particular case. – user3439894 May 14 '17 at 16:08
  • @user3439894 - Let me punctuate your last sentence because I agree - there was zero reason to down vote this answer. – Allan May 14 '17 at 16:15
  • only the terminal version worked. Using System Preferences (making my HD private and than removing it) did not work, even though I restarted/log-off/on. – rul30 Jun 2 '17 at 21:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .