0

Apple Mac Pro (Early 2009) running El Capitan OS 10.11.6 Connecting to the internet via a D-Link DWA-131 WiFi USB Dongle

Hello, I am trying to carry out the infamous 4.1 to 5.1 firmware upgrade so that I can upgrade my existing 10.11.6 OS up to Sierra 10.12. I have established that I need to carry out the following steps:

  1. Boot into recovery mode and disable SIP since I'm running El Capitan
  2. Reboot
  3. Mount the MacProEFIUpdate dmg (for 5.1)
  4. Run MacEFIRom's utility.
  5. Shutdown and power back up by holding the power button until light flashes and beep sounds
  6. Verify Boot ROM Version: MP51.007F.B03
  7. Boot into recovery mode and enable SIP
  8. Reboot
  9. Reset PRAM

The problem comes at step 4. As far as I can see, the act of disabling SIP, also disables my internet connection. This causes a road block because the MacEFIRom utility will only run if the internet is active. So I cannot run step 4 and beyond. I might investigate the possibility of running and Ethernet Cable to the front room where my WiFi Router is, thus bypassing the wireless aspect of the connection. Other than that I'm out of ideas.

Can any anyone tell me how I can achieve all 9 items on the list? Or indeed, if my list of steps is incorrect please can you correct me?

  • Disabling SIP disables your USB which then disconnects your network. Your best bet is to run that Ethernet cable. It's only temporary and will get you sorted out. – Allan May 14 '17 at 0:21
  • 1
    Thanks for the reply Phil. I'll try the Ethernet cable. What's the etiquette on message formats, and on saying "Thanks" for that matter? I just want to be a good "Ask Different" citizen! – carlcaulkett May 15 '17 at 12:30
  • "Thanks" = upvotes. You can upvote comments as well (small arrow to the left of the comment when you hover over it). Simple "Thanks" comments are frowned upon (and may get removed), but there's nothing to stop you from saying "thanks" in a more detailed comment. "Thanks" posted as answers will get removed. – Allan May 15 '17 at 12:57
  • You should write that up as an answer so it can be upvoted and you can "select" it which, in effect, marks it solved. So glad you were able to get it up and running. – Allan May 16 '17 at 14:47
  • Does MacEFIRom require network to run? I may be wrong here but I don't think that it does. Download MacEFIROM utility prior to disabling SIP if so, no network cable required. – little tiny man May 17 '17 at 16:22
1

I ran an ethernet cable and was able to progress through the list of tasks. It took two attempts to pass step 5. The trick was to keep the power button pressed well past the flashing of the power light and only releasing it again after the continuous tone has sounded. Long story short, I now have the 5.1 firmware installed, and have upgraded to Sierra 10.12.5.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .