5

I have a new iMac running OSX 10.12.4. It has an internal Apple-Supplied 512Gb SSD, of which about 140 Gb is used. As with my previous machine, I use Time Machine to backup on to an external 2Tb hard disk.

However, I find that every TM backup appears to be a full backup, not an incremental backup.

How can I get Time Machine to make proper incremental backups, as it’s supposed to?

By way of background,

  • Each backup takes a very long time; so long that it cannot backup hourly because it’s still completing the last backup.
  • On the Preferences panel it tells me that it is backing up … GB of 131 GB.
  • The space left on the drive corresponds to multiplying the number of backups by the full amount of data.
  • After about 18 backups, it starts deleting old backups
  • I get the disk full message too soon

So I am convinced that they’re all full backups.

I have tried everything I can think of, including:

  • turning it off and on again
  • re-formatting the drive
  • replacing the drive
  • reinstalling the OS
  • deleting the plist, as per Pondini’s web site
  • removing some software suspected of interfering with TM
  • excluding additional folders
  • putting chicken feathers in a paper bag and waving it around my head

I have spent countless hour with Apple support. As a desperation move, they now want me to do a clean install, which, in my opinion is going too far, and certainly not something I am enthusiastic.

I am aware of this question: Time Machine keeps doing full backups

but

  • it’s 5 years old
  • the asker says that TM also does incremental backups
  • despite the accepted answer, the question is not really answered
  • What does BackupLoupe say about the last backup which was made? (Seems like this is the same suggestion in the linked post you added in grace period! I'd still be interested to see what it says.) – grg May 13 '17 at 11:44
  • @grgarside Hard to say. It takes a very long time to calculate sizes, which is not a good sign. When it does, each backup is the same size as the original. – Manngo May 13 '17 at 11:46
  • Have you tried analysing the last backup using the load button next to the backup in the sidebar (or is that what you meant by "a long time to calculate sizes")? – grg May 13 '17 at 11:47
  • I have just opened it again, and asked it to re-index everything. However, yes, that is what I mean. – Manngo May 13 '17 at 11:50
  • @grgarside BackupLoupe has finally given me the results on the first 4 backups: all about 130 Gb. Meanwhile there are some more being queued. – Manngo May 13 '17 at 23:32
1

Backups are managed via Apple File System Events (not Spotlight) https://en.wikipedia.org/wiki/FSEvents

It seems most likely that something is touching your files in a way that convinces TimeMachine a new copy is needed. There could also be something damaging the FSEvent cache which would cause TM to create a new backup.

You might want to check the system console log and see if there are any messages there that hint at the underlying problem.

  • Thanks for your comment, giving me somewhere else to look. Would that be related to the Not using file event preflight message I’m getting in my logs? – Manngo May 26 '17 at 5:28
  • I haven't seen that message but it sure sounds plausible from the wording. See what Google says – Daryl Monge May 26 '17 at 14:03
0

My gut reaction is that this sounds like Spotlight isn't indexing properly. Spotlight is how the system knows which files have been backed up and which files have since changed or been added. My first step might be to reset Spotlight by opening Terminal and running this command:

$ sudo mdutil -E /

that'll delete /.Spotlight-V100 and rebuild it on your main volume. Failing that, head on over to http://pondini.org/TM/D7.html - that website is fantastic for troubleshooting Time Machine issues, and that page is dedicated specifically to the problem you're experiencing.

  • @Manngo If you read through and do the steps and find that something there fixes it, post the answer back here and mark it as the correct answer so that people in the future have a good chance of trying your steps first. – Harv May 17 '17 at 7:26
  • Thanks for the suggestion. I think I’ve tried everything on the pondini site, but I’ll have another look. Meanwhile, I have reset Spotlight as you suggested. Of course it will take a while to see whether it works, so I’ll let you know how it goes. – Manngo May 17 '17 at 8:08
0

This doesn’t resolve why the problem arose in the first place, but it certainly fixed the problem.

After spending many hours with Apple support, somebody finally suggested that I reinstall the whole thing and start again. Needless to say, I was reluctant to try that.

However, an Apple Genius whom I consulted on a different matter did mention that doing this and restoring from a Time Machine backup to a fresh setup actually does things differently.

I had enough space on my internal disk to partition it so I could try it out without losing everything.

Here are the steps I followed:

  • Partition the internal drive using Disk Utility
  • Reboot into Recovery Mode
  • Install MacOS into the new partition
  • Reboot into the new partion and follow the usual process
  • When the time comes choose to restore from a Time Machine backup

There were a few minor issues with reconfiguring some things which TM didn’t have, but over all it worked smoothly. It is a pleasure to see it all working properly again.

Phew.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .