1

I run curl I got

-bash: /usr/local/php5/bin/curl: No such file or directory

When I run which curl I got

/usr/bin/curl

When I run /usr/bin/curl --version I got

curl 7.49.1 (x86_64-apple-darwin16.0) libcurl/7.49.1 SecureTransport zlib/1.2.8
Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtsp smb smbs smtp smtps telnet tftp 
Features: AsynchDNS IPv6 Largefile GSS-API Kerberos SPNEGO NTLM NTLM_WB SSL libz UnixSockets

What should I do to be able to run just curl again ?


I never understand much about this export stuffs.

Can someone please shed a little light on this ?

If I run export -p

declare -x Apple_PubSub_Socket_Render="/private/tmp/com.apple.launchd.8nDQkuFrwz/Render"
declare -x DBUS_LAUNCHD_SESSION_BUS_SOCKET="/private/tmp/com.apple.launchd.rRmvUm9NdX/unix_domain_listener"
declare -x DISPLAY="/private/tmp/com.apple.launchd.cw926giJNa/org.macosforge.xquartz:0"
declare -x HOME="/Users/bheng"
declare -x LANG="en_US.UTF-8"
declare -x LOGNAME="bheng"
declare -x OLDPWD
declare -x PATH="/Library/Frameworks/Python.framework/Versions/2.7/bin:/usr/local/sbin:/usr/local/php5/bin:/Users/bheng/.composer/vendor/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/pgsql/bin:/opt/X11/bin"
declare -x PWD="/Users/bheng"
declare -x SECURITYSESSIONID="186a6"
declare -x SHELL="/bin/bash"
declare -x SHLVL="1"
declare -x SSH_AUTH_SOCK="/private/tmp/com.apple.launchd.afZzV5wsc3/Listeners"
declare -x TERM="xterm-256color"
declare -x TERM_PROGRAM="Apple_Terminal"
declare -x TERM_PROGRAM_VERSION="377"
declare -x TERM_SESSION_ID="790013ED-2C1D-4D5E-9BC2-DF773A8473A8"
declare -x TMPDIR="/var/folders/54/y_678c6n7q7_pgk1v5lkzwnr0000gp/T/"
declare -x USER="bheng"
declare -x XPC_FLAGS="0x0"
declare -x XPC_SERVICE_NAME="0"
declare -x __CF_USER_TEXT_ENCODING="0x1F6:0x0:0x0"
1

Given your $PATH has /usr/bin in it, which is where you're finding curl, you should be fine.

Can you run alias to see if it's being overridden somewhere.

alias curl

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .