2

I have MacBook Pro with macOS Sierra. When I try to Log off system I get annyoing confirm dialog each time. Here is it:

It says that it was prompted because of some option enabled. This option here:
“Prefs > General > Confirm Quit iTerm2”.

What ‘Prefs’ is this about?

I have this in System Preferences > General, and iTerm 2 context menu > Edit Session….

Nether System Preferences nor iTerm2 prefs has this checkbox. So how I can disable this confirm dialog on log off?

4

In macOS, you can find the preferences for any app by choosing the app name in the menu bar, then selecting Preferences.

In this case, the preference being referred to is this one:

1

That Preference is an iTerm2 preference.

In iTerm2 go to Preferences, choose the General icon. There is a section on Closing this includes Confirm "Quit iTerm2 (⌘Q)" command

enter image description here

  • Thank you for you answer! That works perfectly. I will accept answer that was first. It is correct too! Thank you very much – Sharikov Vladislav May 12 '17 at 21:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .