1

I have one Mac Mini with Server installed and the NetInstall service On. It looks like this:

Server

I plugged an ethernet cable into this Mini, and plugged the other end into a MacBook. I'm now trying to boot the MacBook to the netboot image.

I tried holding down Option during boot; the only option I see is the local HDD. I tried holding down N during boot; it does not find anything. What else to I have to do to make this work?

I tried turning on the DHCP server on the Mini but that doesn't seem to provide addresses to either machine. Not sure why auto-assigned addresses wouldn't work for this though, since this is just an isolated ad-hoc network.

If this works I will add a network switch so I can do 5-10 Macs at once. So I'm not looking for an easier offline solution that will only let me do one at a time.

  • Auto-assigned = 169.254.0.0/16? Do you run a second DHCP server (i.e a router) in your network? – klanomath May 12 '17 at 19:55
  • Yes and no. Is a router required for this to work? This is just two macs connected by an ethernet cable, not connected to a larger network – squarjn May 12 '17 at 20:47
  • Get a small switch like this Netgear FS105 and use 2 ethernet cables. – IconDaemon May 12 '17 at 23:24
  • A router isn't required unless the they're in different network subnets. A direct ethernet connection will work but you have to configure/enable DHCP on the NetBoot server. Did you configure a pool of address for DHCP? I've never tried this with auto-assigned addresses... If you have a DHCP server available elsewhere on the network then you don't have to enable it in Server.app. – MacManager May 28 '17 at 20:19
  • If all else fails I start looking at packet traces next. BSDP (NetBoot) uses bootp option 43 so you can filter with something like "bootp.option.type eq 43" in Wireshark. – MacManager May 28 '17 at 20:26

You must log in to answer this question.

Browse other questions tagged .