When I have a form that I don't want to print out and write on, I can simply use Preview.app's PDF Annotations feature in order to fill in the necessary fields, and print out the final result.

I have now done this and completely filled out a PDF file, but I'm making a few last minute changes and have run into a problem. The first couple of fields have an annotated text size that is nearly double that of the rest of the fields, and I wish to shrink them to be closer, if not exactly the same size.

But I am unable to do so;

If I click on the text field, as if to resize or move it, then open the Text Properties field and begin changing properties, they do not take effect. If I select text within the text field and again attempt to change properties, they still do not take effect.

Shy of deleting the field and re-typing it with the text properties adjusted prior to doing so, why am I unable to edit text color, size, etc.?

  • Does anyone has an idea how text properties can be accessed in preview on Mojave? – drevicko Jul 10 '19 at 1:40
  • They haven’t changed in Mojave. – Jason Salaz Jul 10 '19 at 1:45
  • Options I get on Mojave for text annotations are: font, colour, font size, bold, italic, underline and 4 alignment options. Other font faces, and eg. line spacing aren't present (though maybe that weren't there before either). Apologies, I didn't phrase my question well: I was after detailed properties (like line spacing). – drevicko Jul 10 '19 at 5:27
  • 1
    Oh, I see, everything that the System font dialog offered (pictured in iolsmit's answer). I don't see how to access those options either, so the answer is to use a different app. Fine grained layout options are definitely way more sophisticated than Preview and quick annotations need to be, you could look into other apps like Pixelmator, Pages, etc. Though, one aside, Font Faces very much are still an option. – Jason Salaz Jul 10 '19 at 6:31

It does work in Lion, the way you tried it.

In Snow-Leopard you have to select the text itself to change the font(size) by first clicking/selecting the text-field to get the selection rectangle (for re-sizing or moving - as you described) and then click a second time on your text to select all the characters. Now your text should be selected (visible by the highlighting) and you will be able to change the font-size in the Text Properties field.



Edit 2012-01-04:

I could reproduce the problem described and also found a simple solution. If you open your pdf and re-arrange pages or rotate them and then try to change the formating of existing text fields it (sometimes) fails.

The solution/fix is to click the window (menu-)bar of the "Fonts" window, then click on your text field again and finally chose the new font variant → and it will be applied :D

click fonts window bar

  • Ok, this is just weird. You're right, it does work exactly as I would have expected. But I obviously wrote this question for a reason, so what was I doing differently or wrong in the first place that made me write this up?! (That's a rhetorical question, btw.) – Jason Salaz Jan 2 '12 at 17:23
  • Ok, I think I didn't read the question thoroughly enough. Does this occur only with a certain file ? Maybe the pdf is corrupt, or the part with the annotations. Or can you reproduce the behavior ? Does it occur after saving the first time or after re-opening ? What OS version are you using ? – iolsmit Jan 2 '12 at 19:03
  • Nonono. That was the 'rhetorical' part of the comment. All I'm saying is, I had this problem, I did exactly what you said in Lion (which I've used since the day it came out, and used when I had the problem that caused me to write this up), but now it works. I'm perplexed as to what I was doing differently before. – Jason Salaz Jan 2 '12 at 22:39
  • A wild guess: sometimes (Apple-)applications lose the track of of pop-up windows and the settings are no longer applied (like the font-settings from the "Fonts" window). Most times it is sufficient to close and re-open the pop-up window to make it work again. In rare cases one has to restart the application. Happens to me in Pages and Numbers from time to time. – iolsmit Jan 2 '12 at 23:52
  • I think I've narrowed down a specific flow in order to do this. Pretty much you have to open a file, open the annotations toolbar (Shift+Command+a, and then select an element, call up the Fonts picker from the Annotations Toolbar, or do whatever change you're going to make. Doing anything else in Preview first seems to blow the whole process out of the water. Could you (1) prove my inability to edit a document if something else is done and (2) prove my startup actions are true? (I'm mostly talking to Nathan, but iolsmit you're welcome to help.) – Jason Salaz Jan 4 '12 at 7:44

To investigate the state of your annotations you could try this Automator workflow:

  • Ask for Finder Items
  • Get Selected Finder Items
  • Extract PDF Annotations

Maybe this gives you a hint why some of the annotations are locked for editing.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .