6

I have a problem with my Wifi driver. I get the message Wi-Fi: No Hardware Installed, which is like the one described here: Wi-Fi: No Hardware Installed

I followed all the instructions given on that page, and from other sites including Apple support. Finally, I tried to remove Wifi from the system preferences and add it back. Unfortunately, adding back a network has no option for Wifi.

I tried networksetup -setairportpower airport on as well. This gives me an error of: You cannot set Wi-Fi power because all AirPort network services are disabled. Any help will be deeply appreciated.

EDIT:

Wifi option not displaying in the Network options.

I updated an screenshot with Wifi not displayed in the wifi setup in system utility.

I tried these approaches:

  • Apple hardware test (Short term): No issues found.

  • Login in safe mode and then reboot, check system preferences same issue.

  • Downgraded to OSX El Capitan (I thought there might be some issue with the upgrade), but the same issue still existed.
  • Again upgraded to OSX Sierra but the issue persisted.

One thing I noticed, when booting from USB, There were no errors like Wi-Fi: No Hardware Installed but the spinner was continuously moving and searching for the networks and it had blank dropdown (without any results). My router was on and WiFi for other devices on the network.

Thanks in advance!

  • Go to System Preferences > Network, select the Wi-Fi network in the left pane, and click the negative sign ( – ) at the bottom (to the left of the gear icon) and delete the network. Click the Apply button. Next, Click the plus sign ( + ) and create a new Wi-Fi network. Click the Apply button. Restart! Does it work? – IconDaemon May 11 '17 at 20:37
  • I can't access That wifi option. I am updating the post with attached Image of it. – rahul_pratap May 11 '17 at 20:55
  • 1
    Did you try booting in Safe Mode? Also try running Apple Hardware Test (AHT). Hold the D key while booting from a powered off state with the AC adapter connected. – Allan May 11 '17 at 21:55
  • 1
    It doesn't seem like your Mac is recognizing any Wifi hardware. What does the System report show? Go under the Apple Menu to "About this Mac" Click on "System Report" and then "Network->Wifi" Is there anything there? – MERM May 26 '17 at 16:25
  • 1
    Do you have the ability to boot up from another system (including Recovery HD) to see if WiFi is working there? It's entirely possible that your WiFi radio is not functioning, and that further troubleshooting of software on that system may be futile. I'd recommend booting up from something else, and determining if WiFi is working so that you aren't spinning your wheels with software fixes (when the issues may be hardware-related). – Eddie Kelley May 30 '17 at 18:31
3
+25

Troubleshooting is a process of elimination and often requires quite a bit of patience. Let's proceed as follows.

Have you followed Allan's advice?

I'm assuming you've already booted into Safe Mode and used Apple Hardware Test (as suggested by Allan in his comment on May 11)?

  • If you haven't, then please follow the steps below for booting into Safe Mode and Running Apple Hardware Test.
  • If you have, can you please edit your question to provide the results of performing both actions. Then skip the steps below for performing these actions and try the Terminal commands I suggest.

Run Apple Hardware Test

  1. Shut down your Mac
  2. Restart your Mac
  3. Press and hold the D key before the gray startup screen appears.
  4. After a while, Apple Hardware Test (AHT) will start.
  5. When prompted, select your language and click the right arrow.
  6. When the AHT console appears, you can choose to run Basic tests by clicking the Test button. However, I suggest you select the "Perform extended testing" checkbox before you click the Test button.
  7. Your test results will appear in the window in the bottom-right of the console.

Take a note of the result and report back.

Note 1: The extended test will take some time. Take a note of the results and report back.

Note 2: If pressing and holding the D key at Step 3 doesn't work, start again at Step 1 and, at Step 3 press and hold both the OptionD keys instead. This will try and run diagnostics from the internet instead, so you will need to allow more time for it to complete.

Boot into Safe Mode

Follow these steps to boot your Mac into Safe Mode:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the Shift key and keep it down
  4. Let go of the Shift key when you see the login window (NOTE: If you have FileVault enabled you may need to log in twice).
  5. Take a note of what happens (i.e. do you see the Wi-Fi option in System Preferences > Network?)
  6. Exit Safe Mode by restarting your Mac as normal
  7. Check System Preferences > Network again

Once you've booted into Safe Mode, let us know how you went.

Now, assuming you still have the problem after already booting into Safe Mode and running Apple Hardware Test, let's proceed with the following course of action.

Run these Terminal commands

Let's confirm what macOS believes the status of your Wi-Fi service is. To do this:

  1. Launch Terminal
  2. Enter the following command:

    sudo networksetup -listallnetworkservices

  3. Press Enter

  4. Enter your password (note you will not see the cursor move, nor the characters appear on the screen)

Now, in the list that appears I assume you will see an asterisk (*) next to the Wi-Fi service. This denotes that it is currently disabled. Assuming this is what happens, let's try enabling it as follows:

  1. Make sure you're still in Terminal
  2. Enter the following command:

    networksetup -setnetworkserviceenabled Wi-Fi on

  3. A popup will prompt you for your password - enter it and click on the Modify Configuration button

  4. Now enter this command:

    networksetup -setairportpower en0 on

  5. Restart your Mac

  6. Now check System Preferences > Network again

Let me know how you go.

  • 1
    I would like to point out that Apple Hardware Test is not actually very helpful for hardware troubleshooting. It takes a long time & doesn't provide much info. – little tiny man May 30 '17 at 0:55
  • 1
    This is true, it does take a minimalist approach in terms of what's reported back to users. However, it's the one tool available to all Mac users (at least in theory). And, when it does detect an error it's extremely accurate and provides enough info to isolate potential problems. That said, it's certainly not my tool of choice for specific hardware tests (e.g. for memory). It's a good place to start for a quick test, but you do often have to use other tools to run much more thorough tests. – Monomeeth May 30 '17 at 1:01
  • That all doesn't solves the issue. Hardware test doesn't seems to display any issue with the computer. And I tried all the steps mentioned but it doesn't seems to work. – rahul_pratap May 30 '17 at 16:52
  • 1
    When you say it doesn't seem to work can you clarify that? For example, when you go through the process of entering the sudo networksetup -listallnetworkservices terminal command (followed by entering your password), what happens? Do you see a list of network services? If so, is Wi-Fi listed? If so, does it have an asterisk (*) next to it? – Monomeeth May 30 '17 at 21:42
  • Wi-Fi is not listed there. – rahul_pratap May 30 '17 at 22:35
2

Can you specify which Mac model & year you're using?

I suspect that this is a hardware issue that needs repaired. These steps will tell if you that's the case.

First try an SMC Reset. You'll find the instructions for this here and an NVRAM reset, instructions here.

Then boot into Recovery Mode by holding CMD + R during startup. This is going to take a bit longer than it normally would to boot - let it run it's course even if takes around 15 minutes.

If the wifi doesn't work there either even after an NVRAM/SMC reset you can be confident that it's a hardware issue. Recovery Mode is overlooked a lot of times as a test bed but it's essentially another installation of OS X that's never been touched or modified, so if it persists you can be sure it's not caused by a faulty kext/program you might've installed.

If the issue is resolved in Recovery it was either by the SMC/NVRAM reset (in which case it will be resolved altogether) or there's an application in your user account causing it, where Safe Mode or creating a new test account in System Preferences > Users & Groups are good next troubleshooting steps.

1

Had the same issues here with no WiFi hardware found, or could not switch WiFi on. WiFi card MAC address showed up in System. Very frustrating

It turned out to be a bad WiFi card. Changed that out and everything came back to normal.

Sometimes the most obvious answer is the correct one

0

The same symptom happened to me just now - “WiFi: no hardware installed”. Turns out it was just a corrupted file, not an actual hardware failure. To make your WiFi come back to life, you need to remove "/Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist" as in drag it to the trash. To find this guy, open a Finder window. Then go to the menu bar for Finder and select "Go" and then "Go to Folder". Then enter "/Library/Preferences/SystemConfiguration" in the dialog box and click "Go" button. Inside the folder that appears you will find "com.apple.airport.preferences.plist". Drag "com.apple.airport.preferences.plist" to the trash. A few seconds later, it will magically resurrect itself and the little WiFi symbol in the header area comes back all on its own. You may need to select the correct WiFi network to connect to, but all is good again.

You must log in to answer this question.

protected by Community Jan 16 at 4:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .