5

I am using a Mac mini. It does not have a keyboard or mouse attached to it. This is by design because I only want to connect remotely to it.

I notice that everytime I reboot my machine. The machine boot sequence gets stuck on a message "Bluetooth Keyboard Setup." There isn't a keyboard connected and it has a circling wheel which says "No keyboards have been found. Make sure your keyboard is discoverable".

I don't want this message. I want my Mac mini to boot fully to a state where someone can remotely connect to it without being blocked by this keyboard message.

How can I do this?

I have already disabled bluetooth on the Mac mini, but it still gets blocked at this screen when it boots.

1
  • Actually, I notice this during sleep as well. I will come back and it fails to detect my keyboard and trackpad. After banging on some function keys (or perhaps after a time period has passed) things return to normal on their own.
    – demongolem
    Apr 27 '20 at 18:46
4

You have to turn off Bluetooth Assistant.

In Preferences, Bluetooth, click the Advanced button, then uncheck "Open Bluetooth Assistant at Startup if no keyboard is detected."

enter image description here enter image description here

Once you turn it off, you should have no problems booting in a headless configuration.

3
  • How can i make clicks with no trackpad? Jun 1 '18 at 9:57
  • @JossieCalderon - I don't know what you mean by that.
    – Allan
    Jun 1 '18 at 12:23
  • You say to click. Jun 2 '18 at 20:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .