I have an iPhone 6. It is the only device in the entire house that picks up the wrong IP address. Other iPhones, non-Apple devices, laptops, desktops, etc. are fine. But my phone is always assigned a link-local IP-address (169.254/16) instead of a private IP-address (192.168/16).

Due to this, it won't even connect to the Internet and I have to type everything manually in Static. I don't want to do this. It was fine till a few days ago. I don't understand the computer terms and would want it to be in layman terms.

Also, we have only one router at home. Everything works well (except my iPhone). Can I understand why this is happening and what can I do to make it right?

PS: The phone is fine. Hardware is fine. I tried the network reset. I tried the software reset too (using iTunes).


First let's clear up some nomenclature inaccuracies...

Your iPhone didn't "pick up" a link-local address from the DHCP server. It assigned itself a private IP based on Automatic Private IP Addressing (APIPA). There's a huge distinction here and is relevant to the problem you are having:

  • DHCP hands out IP addresses based on a configured pool of addresses.
  • APIPA self assigns an address when, for whatever reason, it doesn't get one from DHCP

So, armed with this knowledge, we know one of two things happened:

  • Your DHCP server didn't respond or ignored/denied the request for an address
  • Your iPhone didn't request or it rejected/ignored the DHCP offer.

DHCP server

It's entirely possible that the issue is with the DHCP server on your router. It may have been configured for a small amount of leases and at some point you hit the limit (your previous lease was given to another client). You may have also "blocked" your client (iPhone from the DHCP pool). Given that your iPhone is the only device not connecting, it would be beneficial to look at the router's DHCP config to see if you have any limitations or restrictions in place. Restarting it wouldn't hurt, either.

Your iPhone

It's also entirely possible that an update or a configuration change has "hosed up" your networking configuration. Usually, forgetting the wireless network and re-connecting will solve the issue.

However, one of the best ways to narrow down the possibilities is to connect it to another network. Take it to your favorite coffee shop, a friends house, or anywhere that has a WiFi network that you can attach to easily. If you can connect there, then you know the problem is with your home setup. If it fails on other networks, you most likely have a hardware issue which means it's time to take it in for service.


Perhaps something changed a few days ago that's affecting your iPhone's network settings (e.g. a carrier update, software update, etc).

One thing you can try is resetting your iPhone's Network settings. You do this by:

  1. Navigate to Settings
  2. Tap on General
  3. Swipe up and tap on Reset at the bottom of the screen
  4. Tap on Reset network settings

Keep in mind once you've reset your Network settings you will need to reenter any WiFi passwords again you normally connect to.

Let me know how you go.

  • I have done it already done it. It didn't work.
    – Ani
    May 6 '17 at 6:19
  • 1
    For future reference it's good to include in your question what you've already tried. Have you also tried a full reboot of the iPhone? And what about a reboot of the router? Also, can you think of anything else that happened a few days ago to coincide with this change, either on the phone, router or the network in general (e.g. a new device added to the network, a VPN setup, etc)? Finally, what is the exact model of the router being used?
    – Monomeeth
    May 6 '17 at 6:28
  • Yes, I did. And no, nothing happened. This defect developed suddenly since yesterday.
    – Ani
    May 6 '17 at 6:44
  • The reality is that it's most likely an issue with your router (that doesn't necessarily mean a fault). You will need to investigate things at that end since you've already done the most obvious things on the iPhone. I may be able to help, but since you've said I don't understand computer terms and would want it to be in layman terms, it's going to be easier if you can give me the exact model of your router.
    – Monomeeth
    May 6 '17 at 8:52

Thanks so much Alan for a great explanation of DHCP and APIPA, it was direct exposure of what really goes on in the background.

After nearly running out of my mind and armed with clearer insight I engaged my problem with new vigor only to find out, accidentally interestingly, that I had the wrong password all the time! Oddly enough my iOS never informed me that my password was wrong, it would simply connect with the wrong password and refuse to respond to every attempt by the router to communicate. So the router kept on sending bits of data and my iPhone never made a peep.

So for those who've upgraded their drivers or changed their routers, please ensure that your password is still THE password, it just might save you the nightmare of a lifetime.


My iPhone 4 was connecting to the wrong router (a router upstairs). It started connecting to the correct router once I set HTTP proxy to Auto. On iPhone 4 Settings - WIFI - Click on name of WIFI network - On the bottom of the page.


I had this problem on my iPhone mini 12, from the modem settings(gui: for me) I set the control channel to 36/80 and STBC Tx to off. I also made the wireless connection type 5Ghz. I am using a Netmaster modem, this solves the problem of obtaining the IP address of the phone or computer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .