56

On new Macbook Pro, Power Chime runs. Whenever I delete from core services it comes right back. It makes a sound when plugging in your power cord even when the volume is at 0%.

The solution I have now to disable this annoying sound is an AppleScript application that runs on login to kill the process via terminal. Is there a better way?

  • 1
    What's your address? I'll send you something. LOL Oh wait, maybe I should send it to Tetsujin? :) – Monomeeth May 5 '17 at 7:24
  • unfortunately idont think his solution works. – user7875084 May 5 '17 at 16:22
  • Has anyone tried to just delete the power chime app in the system files folder? – Jake Feb 16 '18 at 18:31
  • OP, you should accept the answer below: apple.stackexchange.com/a/309947/190701 – guyarad Mar 28 '18 at 3:11
  • @Jake sudo rm: /System/Library/CoreServices/PowerChime.app/Contents/MacOS/PowerChime: Operation not permitted – John Jiang Jan 5 '19 at 16:33
82

The solution is to set ChimeOnNoHardware to true instead of setting ChimeOnAllHardware to false (note, No instead of All):

defaults write com.apple.PowerChime ChimeOnNoHardware -bool true
killall PowerChime
| improve this answer | |
  • 5
    Thank you. This what worked for me on high sierra. – SFbay007 Mar 20 '18 at 3:46
  • 2
    I tried this command and got this message: "No matching processes belonging to you were found" – Disco Danny Nov 7 '18 at 4:32
  • 1
    @DiscoDanny use sudo – Matthew Barclay Feb 1 '19 at 3:20
  • 2
    ran this once and it works mostly, but the chime still goes off with the lid closed and the laptop locked/sleeping. – worc Feb 13 '19 at 17:54
  • 6
    Works on Mojave, but yes the chime still goes off w/the lid closed. Also, just from testing this ~5 times I feel like the USB-C cable or port is likely to break in short order. Port is too tight & the cable is as flimsy as they always are from Apple. RIP Magsafe... – mc01 Apr 9 '19 at 17:26
10

Here's another solution since the others provided don't seem to be working for you. You can create an empty AIFF file to replace the default chime. The chime audio is located here:

/System/Library/CoreServices/PowerChime.app/Contents/Resources/connect_power.aif

I created an empty AIFF file using Adobe Audition. With SIP disabled, I backed up the original chime and replaced it with my new audio file:

sudo mv /System/Library/CoreServices/PowerChime.app/Contents/Resources/connect_power.aif /System/Library/CoreServices/PowerChime.app/Contents/Resources/connect_power.aif_bak
sudo mv ~/Desktop/null.aif /System/Library/CoreServices/PowerChime.app/Contents/Resources/connect_power.aif

Be sure to fix the permissions on the file:

sudo chown root:wheel /System/Library/CoreServices/PowerChime.app/Contents/Resources/connect_power.aif
sudo chmod 644 /System/Library/CoreServices/PowerChime.app/Contents/Resources/connect_power.aif

No more audio when connecting your power source.

| improve this answer | |
  • 2
    Thanks a million this worked like a charm! I copied the AIF to the desktop, opened the file, muted it and then saved it. Disabled SIP and replaced it (I didn't use Terminal I just dragged and dropped), then ran those two permissions line commands and BOOM! No more power chime. – Disco Danny Feb 3 '18 at 1:56
  • 1
    This stopped working after updating to OS 10.13.6! I looked at the AIF file and it is silent, so I have NO IDEA how it found that horrible sound again! Now I'm back to square one. – Disco Danny Nov 7 '18 at 4:30
  • Ditto @DiscoDanny. – Philip Jul 26 '19 at 12:50
  • Doesn't work with lid closed on Mojave. – minipif Aug 1 '19 at 3:19
2

I'm using this tool on all MacBooks after 2015, it allows to quickly switch PowerChime sound

https://github.com/DaFuqtor/powerchime

| improve this answer | |
1

In case anyone wants my AppleScript I'm using to stop this:

tell application "System Events"
    delay 3
    set ProcessList to name of every process
    if "PowerChime" is in ProcessList then
        set ThePID to unix id of process "PowerChime"
        do shell script "kill -KILL " & ThePID
    end if
end tell

But really looking for another way. Any help is appreciated. Thanks.

| improve this answer | |
0

Tested on MacBook Air - MacOS High Sierra

Open Terminal and

sudo nvram SystemAudioVolume=%00

You’ll be asked to enter your password.

| improve this answer | |
  • 2
    What does it do? Turn off all sound on a laptop? We do not want all to be OFF – Joe Jan 14 at 16:32
0

On Mojave you can do the following:

ps -eaf | grep Chime
  502 17070     1   0 10:48AM ??         0:00.24 /System/Library/CoreServices/PowerChime.app/Contents/MacOS/PowerChime
  502 17740 16102   0 10:50AM ttys002    0:00.00 grep --color=auto --exclude-dir=.bzr --exclude-dir=CVS --exclude-dir=.git --exclude-dir=.hg --exclude-dir=.svn --exclude-dir=.idea --exclude-dir=.tox Chime

Find the pid of the powerchime app in this case is 17070

then do a:

kill -9 17070

It'll start back up at startup but def kills the process while you're working.

| improve this answer | |
0

None of the previous solutions worked for me. Here's how I permanently disabled the chime on a 2017 MacBook Pro running Catalina (10.15.6):

Disable System Integrity Protection (SIP)

  1. Shut down your computer.
  2. Hold down Command-R and press the power button. Keep holding them down until the Apple logo appears.
  3. Wait for OS X to boot into the OS X Utilities window.
  4. Choose Utilities > Terminal.
  5. Enter csrutil disable.
  6. Enter reboot (or otherwise reboot the computer).

[Source]

Delete the sound file

Upon rebooting, open a terminal, and do the following:

  1. Enter csrutil status to ensure you have disabled SIP. You should see:
System Integrity Protection status: disabled.
  1. Enter sudo rm /System/Library/CoreServices/PowerChime.app/Contents/Resources/connect_power.aif
  2. If prompted, confirm the operation.
  3. If you get an error that includes Read-only file system, enter sudo mount -uw /. This remounts the file system as read-write. Go back to step 2.

Reenable SIP

  1. Shut down your computer.
  2. Hold down Command-R and press the power button. Keep holding them down until the Apple logo appears.
  3. Wait for OS X to boot into the OS X Utilities window.
  4. Choose Utilities > Terminal.
  5. Enter csrutil enable.
  6. Enter reboot (or otherwise reboot the computer).
  7. After rebooting, verify that SIP is reenabled with the terminal command csrutil status.
| improve this answer | |
  • 1
    I appreciate this and tried it after seeing a similar suggestion posted elsewhere, but, to my amazement, the damn thing still chimed even though I thought I had deleted the sound of the chime (including following the disable-delete-reenable scheme). Touché, Apple... – Philip Aug 15 at 23:48
  • @Philip Have you checked if /System/Library/CoreServices/PowerChime.app/Contents/Resources/connect_power.aif still exists? – Ellen Spertus Aug 16 at 17:52
  • 1
    I'm in the same boat as Philip - did the whole dance: ~$ afplay /System/Library/CoreServices/PowerChime.app/Contents/Resources/connect_power.aif Error: AudioFileOpen failed ('wht?') It still chimes. v10.15.6 (19G2021) / MacBook Pro (13-inch, 2020, Four Thunderbolt 3 ports) – tjmcewan Sep 14 at 12:35
  • @tjmcewan That's weird. How about ls /System/Library/CoreServices/PowerChime.app/Contents/Resources/connect_power.aif? – Ellen Spertus Sep 15 at 17:57
  • Yah, sorry I wasn't clear, that file no longer exists. Looks like that file is no longer the source of the sound. The sound even plays when the machine is off & before I've unlocked the Filevault encryption. – tjmcewan Sep 17 at 11:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .