Ever since I purchased the AirPods (1st Generation), they demonstrate extremely poor quality while activating the AirPod mic, whilst they are connected to a Mac. When activating the mic to record audio, it seems that both the recording quality AND audio playback quality severely drops to a substandard level (Mono 8.0 kHz).

For example, if I invoke Siri on the Mac, whatever is being said and recorded by me, AND the Siri/Mac/AirPod audio response will be in poor quality. After the recording is done, audio playback quality usually goes back to normal1. Any mic audio recorded to a file will however be in the poor quality; which is why I interpret the issue to affect both recording and playback qualities.

The issue appears to be identical to the one discussed in this Apple Support Forum thread. The thread offers possible explanations but no definitive solution or suggested course of action.

I have this issue with several Macs of various recent models. I don't have this problem when using the AirPods with an iPhone. I have tried resetting the Mac Bluetooth interface, tried resetting the AirPods, and so forth.

FYI: Using the macOS native application Audio MIDI Setup, I attempted to observe what's happening when AirPod recording is activated. Output quality drops from the standard 2 ch 24-bit Integer 44.1 kHz1 ch 16-bit Integer 8.0 kHz.

enter image description here

1It has happened that the Mac got permanently stuck in low quality until system reboot, or even whenever the AirPods were connected afterwards. I had to attempt AirPod unpair/re-pair, and even a charging case reset to fix the latter situation.

  • Please create a new admin user on your Mac and try to recreate the issue with this account. Is the audio quality distorted in the same way? BTW, I have experienced the same issue in the past.
    – oa-
    Commented May 16, 2017 at 17:54
  • Based off of what you've tried & @oa experience with the same issue, I would guess that this is a bug in OS X. Testing in a new admin account is a great move but if it doesn't work I think the best thing you can do is to continue to update your software. Commented May 17, 2017 at 15:59
  • @oa- Thanks for the suggestion – I have the same issue on my admin account. I would agree that this seems to be firmware or OS-related, unless my AirPods or Mac Bluetooth chip are defective. I don't think the latter is likely however.
    – P A N
    Commented May 17, 2017 at 21:33
  • If applicable, please check your AirPods firmware using a connected iPhone: Settings > General > About > AirPods. Note that this entry one of the last entries and that your AirPods must be connected to your iPhone. What version is displayed?
    – oa-
    Commented May 18, 2017 at 6:58
  • 1
    It's still an issue on Big Sur. Now the behavior appears to be that both input and output switch to mono 16 bit, 16kHz quality. This may be considered an "improvement" but it's still nowhere near high fidelity (32-bit, 44kHz) Commented Jan 25, 2021 at 12:30

10 Answers 10


OP here – I'd just like to add to the answer below, that I've been in contact with Apple Support.


Apple claims that the poor Mono 8kHz quality which affects recording and indeed simultaneously playback on Mac when the AirPod microphones are activated, is because the SCO codec then gets employed over the entire Mac audio system. This is supposedly "expected behaviour" when trying to use the AirPods and other Bluetooth headsets together with a computer, according to Apple.

The AAC codec is normally used when just listening to playback on the AirPods. It's just very unfortunate that SCO – low-quality as it may be – upon AirPod microphone activation is not only limited to doing recording, but also displaces AAC and audio playback.

Apple Support claims that Apple is looking at this issue, and that improvements might be coming in future firmware updates, but I did not interpret that as a promise to be honest. But for the time being, I'd say that the benefits of making calls and so forth with AirPods on Macs are quite limited.

Current best practice

Current best practice is to use the Internal Microphone for Recording, and the AirPods for playback when conducting calls. Input and Output devices can be selected in System Settings > Sound or by -clicking the Volume icon in the macOS Menu Bar, and selecting devices there.

See the screenshots below:

airpods-output internal_mic-output

  • 1
    I can confirm the workaround works, Early 2013 Retina MacBook Pro with mac OS High Sierra.
    – vektor
    Commented Apr 9, 2018 at 8:19
  • 12
    Thanks, the workaround works. But I'm simply shocked that they haven't found a proper fix after 2 years of people reporting this! Commented Aug 6, 2019 at 14:43
  • 1
    This a nice workaround. But mind yourself if you are on an older Mac, like me, the fans might just turn on and mess up with the internal mics. I've been using this "internal mic" solution and had people tell me my mic sounded super low/muffled. So I just bought an external mic to use with my AirPods and while it doesn't arrive I am using an inexpensive wired headset, which people do say sounds better than the AirPods or the internal mic. Commented Aug 13, 2020 at 17:50
  • 1
    This is very disappointing. Here I am with a pair of AirPods Pro with MacBook Pro (Late 2013) in October 2020. I only realized that I sounded like shit today after using this setup for one whole year. I'm embarrassed.
    – Vic Jang
    Commented Oct 10, 2020 at 6:07

I found this on the Apple Discussion boards:

... they are aware of the issues and a temporary workaround is to switch the mic from the AirPods mic to the internal microphone.

On the discussion post you referenced, there was 217 other people reporting that they too had this issue.

Also from a May 6th Apple Tool Box article:

Many of our readers are letting us know that their AirPods are experiencing a lot of challenges while using them with macOS. In particular, when the mic is used, the AirPods’ audio is very low fidelity and sound quality. Some iFolks claim that they cannot even understand the other person when video-chatting with apps like FaceTime, Hangouts, and Skype. And your callers also report that your voice sounds muddy or that they barely hear you at all.

Is there a fix?

Other than the workaround to use your internal mic, no. My advice is to return the unit to Apple. There may be a fix in a future update to macOS or the AirPod firmware, but only Apple knows when they will issue an update. Given that Apple "silently" released the last update, don't expect too much fanfare with the next one.

Personally, I would have returned them and/or opened a support case with Apple as they are the best ones to solve this issue.

This is not an issue with your "bluetooth chip" as per the comments. This would be easy to diagnose - test you MBP with other BT headsets. If the problem goes away, it's the AirPods.

  • 1
    Testing my MBP with other BT headsets gives the same result: when using the microphone from the BT headset, audio codec switches to SCO, giving poor sound quality.
    – mdarwin
    Commented Dec 17, 2018 at 10:52
  • Yes this occurs with other headphones - it is a limitation in macOS (other answers suggest it is in the Bluetooth spec itself)
    – mmmmmm
    Commented Sep 25, 2021 at 18:15

As the answer already states, it's because the AirPods change to the SCO codec. The bad news is, there is no way to permanently change this in macOS High Sierra¹ - there was a way to fix it in macOS Sierra, so if anyone reads this and hasn't yet updated, try this:

Use Apple's developer tool Bluetooth Explorer. Then you can use Audio Options (under Tools in the menu bar) to force them to use the alternative codec aptX.

Full disclosure: Unfortunately I can't try it myself. (This is the first time I regret updating to the newest Apple OS...)

¹ the temporary workaround from the other answer works, obviously, you just have to do it every time.


I just created a little menu bar app that forces the default input to be the built-in microphone of the mac if exists, if not you can choose your desired default input source. No more sound quality drops and it also increases the battery life. It is free and open source:


  • 1
    That's super great. Thanks for it. It works perfectly. Commented May 7, 2019 at 10:06
  • should this tool automatically change the input from the AirPods to the selected input or do I have to manually change it by pressing the "Force input" and choosing one of the other options? Commented Feb 12, 2020 at 7:41
  • This is great. Just mind that if you fan goes loud on, your mic quality will suffer. Mac (and conference software) will try to cancel fan noise and your voice will sound either low or muffled. For those reasons, I recommend either having a wired headset or buying an external mic to use with your AirPods. Commented Aug 13, 2020 at 17:52
  • Brilliant! Thank you!! It worked like a charm. (I changed the app icon myself.)
    – Vic Jang
    Commented Oct 10, 2020 at 22:23

This problem frustrates me to no end. Recently I noticed that when I start a Vagrant/VirtualBox VM (vagrant up), and it prompts me for administrator access (one time I remember it asked for access to the microphone, and I was a bit confused), the audio drops to the low bitrate connection.

I always have my mic set to an external USB mic, and speakers set to AirPods, so it doesn't seem (in my case) to be related to the mic input being set to the AirPods.

However, knowing that I can more easily see what's happening with the Audio MIDI Setup app, I opened it up, and sat there messing with some toggles a bunch of times, until I came up with the following process which set the audio back to the 32-bit 2 channel mode reliably without a full reboot!

  1. Have some audio playing (e.g. iTunes)
  2. Open Audio MIDI Setup
  3. Select your Airpods in the list of devices (the one with 1 out or 2 outs)
  4. Toggle the 'Format' menu from "1 ch 16-bit..." to "2 ch 32-bit..."
    1. Note that this will blip the audio for a few ms, but it will switch back
  5. Keep Audio MIDI Setup open
  6. Disconnect your AirPods to your Mac using the Bluetooth menu
  7. Re-connect your AirPods to your Mac using the Bluetooth menu
  8. Wait for some playing audio to return to your AirPods—it will still be tinny and yucky sounding.
  9. Quit Audio MIDI Setup.

This has worked two times for me; other times I tried restarting... just putting this out there in case it works for someone else!

  • Adding a note that it seems the VirtualBox-specific issue seems to have appeared around the time VirtualBox 5.2.20 was released. See: github.com/palantirnet/the-vagrant/pull/60 Commented Dec 28, 2018 at 3:19
  • Thanks for the pointer. The steps didn’t work for me, but I discovered it’s because I had the AirPods in channel ticked in one of my Audio MIDI Setup aggregate devices. Removing the AirPods in channel from the aggregate device fixed it for me! Wrote up answer here. Commented Aug 9, 2020 at 14:15
  • Switching to and away from the AirPods mic might suffice.
    – cachius
    Commented May 11, 2022 at 11:08

I've been getting crazy with this issue, because as it's described on every call with the iPhone everything was perfect, but not with the mac... which is not very convenient from apple...

Well, I downloaded the "Bluetooth Explorer" from @Alex-Ruyven unofficial link and I tried to force APTx, and it's works partially...

When listening to music, I see it's using the "SBC" ( APTx for apple ) code instead "AAC". And I hear a bit lower music quality for playback music.

The problem is as soon as we connect the microphone, it still changes the code to SCO so still the same problem from the beginning.

Really hoping Apple fix it quickly because having a 100% Apple ecosystem and this issues on calls it's not the idea I got when I bought the AirPods.

Well, hope to see an update soon.


The problem was: I had created an “Aggregate Device” in Audio MIDI Setup which included the AirPods as one of the in channels.

By using the AirPods mic this way, it forced the AirPods to use the SBC codec for its Bluetooth audio communication (which you can verify by option-clicking the Bluetooth menu and hovering over your AirPods device, and it will show you the RSSI levels and audio codec being used).

This meant terrible quality mono audio

To fix the issue, I simply removed the AirPods as an in channel from the Aggregate Device in Audio MIDI Setup.

You may also need to explicitly go into the AirPods out device in Audio MIDI Setup and configure the “Format” menu to be “2 ch 32-bit float (48.0 kHz)” instead of “1 ch 16-bit (8.0 kHz)”.

Note: changing the format won’t work (it will blip back to “1 ch 16-bit (8.0 kHz)” if you have the AirPods in channels configured anywhere else in Audio MIDI setup).

After doing this, the AirPods reverted to their high-quality stereo output.


The workaround to this in the OP's answer is effective, except in one particular scenario I've come across.

Online meeting and conferencing software like Zoom can actually override the Mac system settings, so that when you change the settings in your Mac sound preferences, nothing actually happens, which is undoubtedly frustrating.

The fix is quite simple: go into your conferencing software (in my case Zoom) and change the mic source there. :)

AirPods Pro aren't so pro after-all. Hope this helps someone!


An upgrade to macOS Monterey seems to improve the minimum sampling rate of both the input and the output of Airpods Pro from 8KHz to 24KHz.

enter image description here

Personally I have found that this level of quality is sufficient for voice calls, so the workaround using the built-in microphone is not needed anymore.

I also find the quality equivalent to voice calls I make on my Android phone.

  • Confirming this change is active on macOS Ventura with AirPods (2nd Gen). There's some helpful info (and links) here for the AAC-ELD codec that makes this quality improvement possible: appleinsider.com/articles/22/02/01/… I agree that it's better...but still not great.
    – nicksuch
    Commented Apr 27, 2023 at 20:04

Had this issue today, and I tried everything else in this thread and I couldn't get it working. After chatting with apple support (in the MacBook department, not the AirPods department).

I had to delete some configuration files and then reset the NVRAM. Here are the files to delete:


The first one wasn't present for me, but I deleted the other two. Then I reset the NVRAM following the instructions here.

Good luck!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .