30

Ever since I purchased the AirPods a month ago, they demonstrate extremely poor quality while activating the AirPod Mic, whilst they are connected to a Mac. When activating the Mic to record audio, it seems that both the recording quality AND audio playback quality severely drops to a substandard level (Mono 8.0 kHz).

For example, if I invoke Siri (on the Mac directly, or by double-tapping on AirPod), whatever is being said and recorded by me, AND the Siri/Mac/AirPod audio response will be in poor quality. After the recording is done, audio playback quality usually goes back to normal1. Any mic audio recorded to a file will however be in the poor quality; which is why I interpret the issue to affect both recording and playback qualities.

The issue appears to be identical to the one discussed in this Apple Support Forum thread. The thread offers possible explanations but no definitive solution or suggested course of action.

I have a Late-2013 MacBook Pro Retina. I don't have this problem when using the AirPods with an iPhone 6s. I have tried resetting the Mac Bluetooth interface, tried resetting the AirPods, and so forth.

AirPod model: A1523. Firmware: 3.5.1. Hardware version: 1.0.0


FYI: Using the macOS native application Audio MIDI Setup, I attempted to observe what's happening when AirPod recording is activated. Output quality drops from the standard 2 ch 24-bit Integer 44.1 kHz1 ch 16-bit Integer 8.0 kHz.

enter image description here


1It has happened that the Mac has been permanently stuck in low quality until system reboot, and even whenever the AirPods are reconnected afterwards. I had to try AirPod unpair/re-pair, and even AirPod charging case reset to fix the latter situation.

  • Please create a new admin user on your Mac and try to recreate the issue with this account. Is the audio quality distorted in the same way? BTW, I have experienced the same issue in the past. – oa- May 16 '17 at 17:54
  • Based off of what you've tried & @oa experience with the same issue, I would guess that this is a bug in OS X. Testing in a new admin account is a great move but if it doesn't work I think the best thing you can do is to continue to update your software. – little tiny man May 17 '17 at 15:59
  • @oa- Thanks for the suggestion – I have the same issue on my admin account. I would agree that this seems to be firmware or OS-related, unless my AirPods or Mac Bluetooth chip are defective. I don't think the latter is likely however. – Winterflags May 17 '17 at 21:33
  • If applicable, please check your AirPods firmware using a connected iPhone: Settings > General > About > AirPods. Note that this entry one of the last entries and that your AirPods must be connected to your iPhone. What version is displayed? – oa- May 18 '17 at 6:58
  • I used to have the problem described here, but now can no longer reproduce it. (To try to reproduce, I'm playing a song via iTunes, then triggering Siri from AirPods, asking something via Siri, then resuming the song.) Audio quality stays good now. Creating an audio recording via QuickTime Player also results in a high-quality recording. I wonder if Apple fixed this? macOS Sierra 10.12.6 + AirPods 3.7.2. I may need different steps to reproduce? (I was planning to give areilly.com/2017/07/29/… a try, but now don't need to.) – Wim Leers Dec 29 '17 at 23:51
22

OP here – I'd just like to add to the answer below, that I've been in contact with Apple Support.

Explanation

Apple claims that the poor Mono 8kHz quality which affects recording and indeed simultaneously playback on Mac when the AirPod microphones are activated, is because the SCO codec then gets employed over the entire Mac audio system. This is supposedly "expected behaviour" when trying to use the AirPods and other Bluetooth headsets together with a computer, according to Apple.

The AAC codec is normally used when just listening to playback on the AirPods. It's just very unfortunate that SCO – low-quality as it may be – upon AirPod microphone activation is not only limited to doing recording, but also displaces AAC and audio playback.

Apple Support claims that Apple is looking at this issue, and that improvements might be coming in future firmware updates, but I did not interpret that as a promise to be honest. But for the time being, I'd say that the benefits of making calls and so forth with AirPods on Macs are quite limited.

Current best practice

Current best practice is to use the Internal Microphone for Recording, and the AirPods for playback when conducting calls. Input and Output devices can be selected in System Settings > Sound or by -clicking the Volume icon in the macOS Menu Bar, and selecting devices there.

See the screenshots below:

airpods-output internal_mic-output

  • 1
    I can confirm the workaround works, Early 2013 Retina MacBook Pro with mac OS High Sierra. – vektor Apr 9 '18 at 8:19
16
+50

I found this on the Apple Discussion boards:

... they are aware of the issues and a temporary workaround is to switch the mic from the AirPods mic to the internal microphone.

On the discussion post you referenced, there was 217 other people reporting that they too had this issue.

Also from a May 6th Apple Tool Box article:

Many of our readers are letting us know that their AirPods are experiencing a lot of challenges while using them with macOS. In particular, when the mic is used, the AirPods’ audio is very low fidelity and sound quality. Some iFolks claim that they cannot even understand the other person when video-chatting with apps like FaceTime, Hangouts, and Skype. And your callers also report that your voice sounds muddy or that they barely hear you at all.

Is there a fix?

Other than the workaround to use your internal mic, no. My advice is to return the unit to Apple. There may be a fix in a future update to macOS or the AirPod firmware, but only Apple knows when they will issue an update. Given that Apple "silently" released the last update, don't expect too much fanfare with the next one.

Personally, I would have returned them and/or opened a support case with Apple as they are the best ones to solve this issue.

This is not an issue with your "bluetooth chip" as per the comments. This would be easy to diagnose - test you MBP with other BT headsets. If the problem goes away, it's the AirPods.

  • Testing my MBP with other BT headsets gives the same result: when using the microphone from the BT headset, audio codec switches to SCO, giving poor sound quality. – mdarwin Dec 17 '18 at 10:52
8

As the answer already states, it's because the AirPods change to the SCO codec. The bad news is, there is no way to permanently change this in macOS High Sierra¹ - there was a way to fix it in macOS Sierra, so if anyone reads this and hasn't yet updated, try this:

Use Apple's developer tool Bluetooth Explorer. Then you can use Audio Options (under Tools in the menu bar) to force them to use the alternative codec aptX.

Full disclosure: Unfortunately I can't try it myself. (This is the first time I regret updating to the newest Apple OS...)

¹ the temporary workaround from the other answer works, obviously, you just have to do it every time.

6

This problem frustrates me to no end. Recently I noticed that when I start a Vagrant/VirtualBox VM (vagrant up), and it prompts me for administrator access (one time I remember it asked for access to the microphone, and I was a bit confused), the audio drops to the low bitrate connection.

I always have my mic set to an external USB mic, and speakers set to AirPods, so it doesn't seem (in my case) to be related to the mic input being set to the AirPods.

However, knowing that I can more easily see what's happening with the Audio MIDI Setup app, I opened it up, and sat there messing with some toggles a bunch of times, until I came up with the following process which set the audio back to the 32-bit 2 channel mode reliably without a full reboot!

  1. Have some audio playing (e.g. iTunes)
  2. Open Audio MIDI Setup
  3. Select your Airpods in the list of devices (the one with 1 out or 2 outs)
  4. Toggle the 'Format' menu from "1 ch 16-bit..." to "2 ch 32-bit..."
    1. Note that this will blip the audio for a few ms, but it will switch back
  5. Keep Audio MIDI Setup open
  6. Disconnect your AirPods to your Mac using the Bluetooth menu
  7. Re-connect your AirPods to your Mac using the Bluetooth menu
  8. Wait for some playing audio to return to your AirPods—it will still be tinny and yucky sounding.
  9. Quit Audio MIDI Setup.

This has worked two times for me; other times I tried restarting... just putting this out there in case it works for someone else!

3

I just created a little menu bar app that forces the default input to be the built-in microphone of the mac if exists, if not you can choose your desired default input source. No more sound quality drops and it also increases the battery life. It is free and open source:

http://www.milgra.com/airpods-sound-quality-fixer.html

  • 1
    That's super great. Thanks for it. It works perfectly. – Răzvan Ciocănel May 7 at 10:06
1

I've been getting crazy with this issue, because as it's described on every call with the iPhone everything was perfect, but not with the mac... which is not very convenient from apple...

Well, I downloaded the "Bluetooth Explorer" from @Alex-Ruyven unofficial link and I tried to force APTx, and it's works partially...

When listening to music, I see it's using the "SBC" ( APTx for apple ) code instead "AAC". And I hear a bit lower music quality for playback music.

The problem is as soon as we connect the microphone, it still changes the code to SCO so still the same problem from the beginning.

Really hoping Apple fix it quickly because having a 100% Apple ecosystem and this issues on calls it's not the idea I got when I bought the AirPods.

Well, hope to see an update soon.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .