3

I moved from just using zsh to using zsh inside tmux. As my terminal is iTerm2 for both combinations.

I have the following lines in my .zshrc to enable jumping words on a bare zsh command line using the ALT+arrow keys:

bindkey '[C' forward-word
bindkey '[D' backward-word

Sadly this is not working inside my tmux session.

How can I jump words back and forth also in tmux using ALT + arrow key?

What I tried so far:

  1. set-window-option -g xterm-keys on 1
1

If found the solution here https://superuser.com/questions/427163/altarrow-moving-between-words-in-zsh-and-iterm2

You have to adjust the keybindings for ⌥ ← and ⌥→ inside iTerm2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .