1

I am new to using macs. I was using the bash shell, but recently tried switching to using iTerm2 and zsh. Originally, it looked the way I wanted, but something changed and reformatted my shell.

Basically I want my user prompt when it opens to look like this... I want to go back to the original iterm2 and zsh defaults

https://draculatheme.com/iterm/

Instead of the -> , my terminal has Username@PCname: ~%

Edit

ECHO $SHELL gives

/bin/bash

more /etc/shells outputs:

List of acceptable shells for chpass(1).
Ftpd will not allow users to connect who are not using
one of these shells.

/bin/bash
/bin/csh
/bin/ksh
/bin/sh
/bin/tcsh
/bin/zsh
  • Would adding PROMPT='%F{magenta}->' to your .zshrc work for you? – fd0 May 3 '17 at 16:09
  • Didn't work. Can I start over? E.g. start from the bash shell that comes with the terminal , uninstall iterm and zsh and then reinstall? – user6754289 May 3 '17 at 17:10
  • Reinstalling won't delete any config files like .zshrc etc – nohillside May 3 '17 at 22:23
0

It looks like your shell is currently set to bash.

From the iTerm2 profiles menu select open profiles. Now you can either create a new profile or modify the default. If you click edit profile this will bring up a preferences window. On this configuration window you can set the "Command" to /bin/zsh.

Hope that works for you.

  • If you create a new profile you'll need to set it as default or access it from the Profile menu. Otherwise a solid answer. – Todd Dabney May 4 '17 at 7:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .