5

I'm running OX 10.11.6 and using the stock Photos app. Whenever I attempt to access the media browser from the Finder file upload box, such as when attaching a photo to an email or social media post, I am unable to access my library. The finder gets stuck in a loading state, forcing me to open the Photos app itself, drag the file to my desktop, and then attach it that way. It goes without saying that this manual approach is extremely cumbersome.

Here's a screenshot of what I see when I try to access my photo library from the finder: enter image description here

Now I've read numerous posts on this same issue that suggest going to Photos > Preferences > General and checking if the photo library is the system default. This usually solves the problem for people, however I've already done that to no effect. See screenshot below: enter image description here

I've also tried rebooting my machine, repairing the photo library and then rebooting again, but to no avail. Upgrading my OS X install isn't an option for me because I'm on an older machine (2009 13" MacBook Pro) that is no longer supported.

Is there any way to remedy this issue that doesn't involve reinstalling OS X?

  • For clarification - how large is the library ACIDSTEALTH.photoslibrary? – I0_ol May 10 '17 at 7:35
  • It's 18.33 GB as of this morning. – Daniel Bonnell May 10 '17 at 15:17
  • Try to show it in Finder. – NullCoderExists May 13 '17 at 1:39
  • What do you mean by "show it in the finder"? – Daniel Bonnell May 13 '17 at 4:11
2
+25

I'm wondering if an application/bug/corrupted setting is causing this. We can test that by trying it on a completely blank slate by creating a new OS X account real quick.

You can do this over in Users, Systems & Groups in System Preferences. Create a new admin user account (no iCloud necessary) restart into the new account & test there, ideally with the same exact photos library. I would share the one you have, here's a how to about it on the Apple support site.

  • Unfortunately this didn't have any effect. I followed the steps exactly. I first tried with an empty library and then with the same library I have but got stuck on the same finder file upload window as before. Sorry for the super slow response. – Daniel Bonnell May 16 '17 at 4:29
  • So it did work with an empty library but not yours? If this is the case I believe it indicates an issue with your library - I have an idea on how to possibly fix this – little tiny man May 16 '17 at 5:58
  • No, it didn't work with the empty library. That would suggest that it's a system problem rather than something specific to the library, right? – Daniel Bonnell May 17 '17 at 14:06
  • Yep... In terms of solutions there's really not much else to do but reinstall. You could try to repair permissions in Disk Utility but that's a complete shot in the dark. I know you're hesitant, but if you enter recovery mode (command + R during startup) you can safely reinstall on top of your existing installation - no backing up/restoring required. Your data & user accounts will be safe. If you have a few hours or don't need the machine on while you sleep I would give it a shot. – little tiny man May 17 '17 at 15:49
  • I'll try the disk repair option but yeah, I'm too hesitant to reinstall since it's my work machine and I'll probably be getting a newer machine in the next few months anyways. Guess I might just have to live with it for awhile. Thanks! I'll let you know if the disk repair worked – Daniel Bonnell May 17 '17 at 17:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .