2

I have a MacBook Pro Mid 2010 running OS Sierra. I recently put a new SSD in, it is HFS+ Journaled and Encrypted. When I use Disk Utility's First Aid, it tells me, it needs to be repaired:

firstaid

The problem is when I start in Recovery Mode, my SSD is encrypted so does not mount. When I click on it to mount it, the password box comes up, but the keyboard is not working at all. I have looked at other answers on the site but they seem to be for USB or wireless keyboards, not a laptop inbuilt keyboard.

Short of totally unencrypting the drive, so that I don't have this keyboard mounting issue, then re-encrypting it, what can I do to get keyboard working in recovery mode / mount this drive so the OS can do these repairs?

  • Why don't you just plug a USB keyboard into it? Any USB keyboard should work (even if you have to borrow a neighbour's keyboard). Worst case scenario you can buy one for next to nothing. – Monomeeth May 3 '17 at 11:39
  • Thanks Monomeeth for idea. I tried this and unfortunately it does not work. Power is going to USB keyboard (caps on and off) but nothing comes into input box when you type. Any other suggestions? – micstr May 4 '17 at 5:49
  • I've just added an answer with steps on resetting your NVRAM. Try that next and see how you go. – Monomeeth May 4 '17 at 5:58
  • I tried the NVRAM reset but this still did not work with either keyboard. It is so weird the laptops's own keyboard does not work in recovery mode. – micstr May 4 '17 at 12:16
  • 1
    Your situation has been bugging me all day and then I had a D'oh moment and realised we could kill two birds with one stone by trying to unlock your encrypted drive via Terminal. If it works, then all is good. If it doesn't work, but you can still enter the commands in terminal, then we also know you haven't got a keyboard problem, but something else is going on. And finally, If it doesn't work because you can't enter the commands in terminal, then we know it's keyboard related. So, I've edited my answer to include steps on using Terminal in Recovery Mode to unlock your encrypted drive. – Monomeeth May 5 '17 at 7:16
1

I was able to resolve the problem of the keyboard not working in Recovery Mode by first reseting the System Management Controller as described in the following article: https://support.apple.com/en-us/HT201295

After that was complete, when I booted into Recover Mode, I was able to use the keyboard. Also, the Utilities menu appeared in the menu bar after the the reset (before the reset, the only menu item was "Language Chooser" which had options).

  • Thanks Andrew - this finally solved it. I managed to Repair but unfortunately I had a scrambled drive (code 08?) and had to Erase drive, reinstall OS and recover from my Time machine. (To those doing this - Its handy to create a shadow Admin account so you can keep restore Time Machine into your original admin account. It was not allowing an overwrite of same username, option greyed out.) – micstr Apr 29 '18 at 20:17
1

As a first step I would try resetting your NVRAM to see if that allows you to enter your password. It's unclear whether you'll be able to do this, since you need your keyboard to do so - but we actually don't know if the keyboard is the issue. In fact, since the USB keyboard didn't work, I suspect it's something else.

Reset NVRAM

Follow these steps:

  1. Shut down your machine. Yes, a full shut down, not just logging out.
  2. Press the power button and then press the commandoptionPR keys. You have to make sure you press these keys before the gray screen appears or it won’t work.
  3. Hold those keys down until your Mac reboots again and you here the startup chime.
  4. Let go of the keys and let your Mac reboot normally.

Note: When you log back in you may need to readjust some of your system preferences (e.g. speaker volume, screen resolution, startup disk selection, time zone information, etc).

If you don't hear your Mac reboot and play the startup chime again, then try the above steps from scratch, but try using the USB keyboard instead.

Let me know how you go.

Use Terminal in Recovery Mode to unlock your encrypted drive

Okay, since resetting the NVRAM didn't change things I suspect that this may not be a keyboard issue, but something else related to entering the password. So let's test this theory by trying to unlock your volume via Terminal.

Follow these steps:

  1. Boot your Mac into Recovery Mode
  2. Launch Terminal (Utilities > Terminal)
  3. Enter the filling command in Terminal: diskutil list
  4. Now, because you have an encrypted volume you should see something like this:

    Logical Volume DriveName on disk2s2
    123E4567-E89B-12D3-A456-426655440000
    Locked Encrypted
    
  5. Now, to interpret the above example: DriveName will be the name of your drive, and the next line (i.e. the 123E4567-E89B-12D3-A456-426655440000 in my example) will be what is known as the universally unique identifier (UUID). This identifier will be a string of alphanumeric characters in a 8-4-4-4-12 format. The UUID is what you will need to unlock your encrypted drive.

  6. Enter the following command in Terminal: diskutil coreStorage unlockVolume <uuid>

    NOTE: Replace the <uuid> with the actual UUID for your drive.

  7. You should now be prompted for your password

  8. Enter the password (don't worry if you don't see the cursor move)

  9. Press enter

NOTE: If you can't enter any commands in Terminal then we know the problem lies with your keyboard input. Either way, let me know how you go.

  • Sorry I have been away. When I boot into Recovery Mode then there is no Terminal option on my list. I have given up and am now decrypting my whole drive which is taking a very long time. Thanks for all your help. – micstr May 21 '17 at 18:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .