2

Boot Camp Assistant says this:

The startup disk must be formatted as a single Mac OS Extended (Journaled) volume or already partitioned by Boot Camp Assistant for installing Windows.

But when I try to go into disk utility, I have a single partition, Macintosh HD (stock partition), not counting the system 18 MB partition, and it is indeed a "Mac OS Extended (Journaled)" format.

What can I do? Does that small 18 MB partition actually make that much of a difference? I can't delete it, so it seems to be important.

diskutil list gives:

 rikermacbookpro:~ rikerw$ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage Macintosh HD            398.8 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s6
   4:                        EFI NO NAME                 104.9 MB   disk0s4
   5:         Microsoft Reserved                         16.8 MB    disk0s5
/dev/disk1 (internal, virtual):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Macintosh HD           +398.5 GB   disk1
                                 Logical Volume on disk0s2
                                 A2648FC0-6D9F-4DB8-98FF-22D33E028A4E
                                 Unencrypted
/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *250.1 GB   disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:                  Apple_HFS Riker Backup            249.7 GB   disk2s2

And sudo gpt -r show disk0:

rikermacbookpro:~ rikerw$ sudo gpt -r show disk0
      start       size  index  contents
          0          1         PMBR
          1          1         Pri GPT header
          2         32         Pri GPT table
         34          6         
         40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
     409640  778989752      2  GPT part - 53746F72-6167-11AA-AA11-00306543ECAC
  779399392    1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
  780668928     204800      4  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
  780873728      32768      5  GPT part - E3C9E316-0B5C-4DB8-817D-F92DF00215AE
  780906496  196198531         
  977105027         32         Sec GPT table
  977105059          1         Sec GPT header
  • Can you edit your question to include the output of terminal command 'diskutil list'? – NoahL Apr 30 '17 at 22:36
3

Try to delete volumes disk0s1,s4 ans s5 with:

diskutil eraseVolume Free Space /dev/disk0s1

and respectively 0s4 and 5 then launch BCA.

Hope this solves the problem.

  • This didn't error, but it didn't solve my problem either. If I run it from standard terminal, it says it's already in use. If I run it from recovery mode, it says it works, but didn't actually work. – Riker May 1 '17 at 14:34
  • @Riker guess you would have to unmount the volumes first – xXREKTERxX May 2 '17 at 5:25
2

Your main volume mustn't contain more than three partitions to allow Boot Camp Assistant to add a Windows partition. These are one visible partition:

The startup disk must be formatted as a single Mac OS Extended (Journaled) volume

and two invisible partitions: EFI and the recovery partition.

To return to the default disk layout you have to delete the last two partitions (disk0s4 – the No Name EFI – and disk0s5 – Microsoft Reserved) and expand the main partition disk0s2.

  • Backup your main volume
  • Detach your backup drive
  • Boot to Internet Recovery Mode
  • Open Terminal in the menubar > Utilities > Terminal
  • Enter diskutil list and with the disk identifier of the internal disk found there: gpt -r show diskX. Usually it's disk0 - below I assume it's disk0. Use the disk identifier you have found in your environment in the commands below! You also have a CoreStorage volume (e.g. FileVault). Check its disk identifier also. Below I assume it's disk2. If you haven't mounted it (because you didn't unlock it - if it is encrypted), you don't have to unmount it below.
  • Verify the disk with diskutil verifyDisk disk0 and diskutil verifyVolume disk0s2. If you get errors try to repair them with repairDisk/repairVolume. If you can't repair the errors add a comment to the answer mentioning the error message(s) and don't continue with the steps below.
  • Unmount the logical volume and then the internal disk:

    diskutil umountDisk /dev/disk2
    diskutil umountDisk /dev/disk0
    
  • Remove the fourth and fifth partition:

    gpt remove -i 5 /dev/disk0 
    diskutil umountDisk /dev/disk2
    diskutil umountDisk /dev/disk0
    gpt remove -i 4 /dev/disk0 
    
  • Reboot

  • Open Terminal and enter diskutil cs list to get the UUID of the logical volume
  • Resize your main partition to the full available size:

    diskutil cs resizeStack lvUUID 0g
    

    In your case that's

    diskutil cs resizeStack A2648FC0-6D9F-4DB8-98FF-22D33E028A4E 0g
    

    In macOS Sierra the magic size 0g often doesn't work and you have to use a real size like 499600m. If you get an error like: Error: -69771: The target disk is too small for this operation choose a slightly smaller size like 499500m until you are successful.

    If you get another error, the whole (previous) Boot Camp Assistant operation failed and corrupted the internal structure of the LVG. You have to restore the main volume from your Time Machine backup then.

  • Quit Terminal.app and launch Boot Camp Assistant to install Windows.
  • This errors at unmounting disk0. It says it's already partitioned or something, and can't unmount. (this is with unmountDisk, not unmount) – Riker May 1 '17 at 14:34
  • @Riker Please add the whole error message! You first have to unmount the logical volume and then the underlying disk. In your diskutil list output that's first disk1 and then disk0. In Internet Recovery Mode it can be different e.g. disk2 and then disk0 or disk13 and then disk0. Simply check your diskutil list output in Recovery Mode and don't be confused by the 11-14 other disks (which are much smaller <1.2 GB) – klanomath May 1 '17 at 16:05
-1

Make macintosh HD the only partition formated as Mac OS Extended (Journaled). that worked for me

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .