For years of development I've never had this issue. Today my Galaxy S7 Edge (Android 7.0) suddenly isn't detected via USB connection by my MacBook (El Capitan). AFT, adb, Unity, nothing detects it any more.

Same for both USB ports. Bought a new USB cable, didn't fix the issue. Tried killing adb server, to no avail. Restarting phone doesnt help. USB ports do work with other devices. Only solution is to restart computer. Then it's detected for a few minutes but as soon as I build my android app on Unity3D and push to phone, the phone is again not detected shortly afterwards. Would have to restart my computer after every new build.

I haven't changed anything, been doing this process all the time without problem until now. How is this possible?

  • Have you tried on another computer? – William Apr 30 '17 at 16:23
  • I currently have no access to other computers. But as the issue is temporarily fixed upon restarting computer, it is indeed a computer (rather than phone) related bug I guess – Kristof Apr 30 '17 at 16:28
  • @yourmather boot into a linux live cd and test it there. You can't eliminate that the phone may not be the issue. – William Apr 30 '17 at 16:29
  • @William thanks but I've never used the solution you mention. Would you mind sharing a little more info on what's that? – Kristof Apr 30 '17 at 16:36
  • 1) Download ubuntu 2) follow this guide apple.stackexchange.com/questions/18314/… – William Apr 30 '17 at 16:38

You must log in to answer this question.

Browse other questions tagged .