2

I have a keyboard shortcut set for lockscreen - ctrl-shift-F15 but if the finder menu bar is visible, the shortcut doesn't work. This is in El-Capitan on a macbook pro 2015 and I am using an external microsoft natural keyboard 4000.

I followed these steps in setting up the lockscreen shortcut:

http://www.macyourself.com/2013/01/27/how-to-lock-your-mac-screen-with-a-keyboard-shortcut

Thank you !

  • What version of macOS are you running? And what model Mac have you got? – Monomeeth Apr 30 '17 at 10:11
  • El Capitan Mac Book Pro 2015 but I am using an external keyboard a microsoft natural 4000. – Fresh Codemonger Apr 30 '17 at 16:35
2

Without knowing your exact model of Mac and version of macOS, I have a different way for you to achieve the exact same thing without having to create an Automator service and setting a keyboard shortcut.

Follow these steps:

  • Go to Apple > System Preferences
  • Click on Security & Privacy
  • Select the General tab
  • Tick the checkbox for requiring a password after sleep or screensaver begins (if you can't tick it, unlock the Padlock at bottom left of the window). Note: You may need to enter a password to make the change.
  • Now from the associated drop-down, select Immediately
  • Exit System Preferences

Now you can lock the screen with one of two built-in macOS keyboard shortcuts (depending on your Mac model):

  1. Control+Shift+Eject
  2. Control+Shift+Power Button

The above macOS shortcuts will put your display to sleep, and because of the change in your Security & Privacy preferences, this will activate the password prompt upon waking it up.

Touch Bar models

If you have a 2016 MacBook Pro with Touch Bar, the above keyboard shortcuts aren't available. Instead, you can:

  • Go to Apple > System Preferences
  • Click on Keyboard
  • Click on the Customize Control Strip button
  • From here you'll see options for either a Lock Screen button or a Display Sleep button
  • Select one of these
  • Exit System Preferences

You can now lock your screen by pressing a button on the Touch Bar.

  • Thank you. Outside of the lock icon when using a non-mac keyboard I still like the lock shortcut it would just be nice if it worked when the finder menu bar was visible. I have put the lock button into the top menu bar tray and I use that when I don't want to loose my vpn access. For some reason the lockscreen method above when locking the screen causes my vpn to disconnect though other tasks that run in the background appear to be fine. – Fresh Codemonger Apr 30 '17 at 16:39
  • If you're connecting to your VPN via Wi-Fi, you may want to read the various answers to this question as they offer many solutions to a Wi-Fi disconnection during screen lock. – Monomeeth Apr 30 '17 at 22:25
  • Wired connection. I tested it again and same thing I used the crtl-shift-f15 and it shows my screensaver and the cisco vpn drops the connection. Clicking the lock icon in the tray of the ios menu bar works and does not drop the vpn connection. Any more thoughts on why the keyboard shortcut wouldn't work with the finder being the active program? – Fresh Codemonger Apr 30 '17 at 22:50
  • Not really, but I do have a suggestion re your dropped vpn connection. Namely you would create a new location and then ensure that your wired (I assume ethernet) connection is at the top of your Service Order. Go to System Preferences > Network. At the top use the Location drop-down to select Edit Location. Click on the plus button to add a new location (e.g. Home). Click Done. Now, on your main window, ensure you have the new location selected... – Monomeeth Apr 30 '17 at 23:11
  • ...Now, click on the cog icon and select Set Service Order... In the list that appears, ensure your vpn connection is at the top (just click and drag). Make sure other items are also in the order you want. Click OK. While you're at it, on the main Network preference window you may want to totally remove any services you know you won't use (select and click the minus button). Then click the Apply button and exit System Preferences. – Monomeeth Apr 30 '17 at 23:12
0

The custom short cut started working. A few built in shortcuts stopped working like command-space for spotlight search and command-tab for application switching. I had virtualbox machines running but the windows were minimized. After closing the running virtualbox machines - the shortcuts including the custom shortcut started working again. I can only assume that somehow the host key capturing done by the virtualbox machines wasn't correctly returned on application minimization and that by closing the running virtual machines the host key (command) was returned to the host (mac) os.

That makes more sense for the built in host key (command) shortcuts but the custom shortcut that had stopped working only when the finder menu was displayed doesn't use the hostkey. It was ctrl-shift-f15 and why it was only not working when the finder menu was visible is also really odd. The built in shortcuts completely stopped working - though the spotlight search icon from the menu tray continued to function properly.

I would have tried logging out and back in or rebooting if I had suspected that this shortcut had previously worked when the finder menu was active but due to my relative recent switch over to mac I didn't notice that it stopped working - only that it wasn't working.

Thanks for all the help and suggestions on this issue!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .