0

I am having some problems searching and sorting data on my internal RAID drive. I have a Mac Pro tower (10.12.4) with five internal drives. One is a SATA SSD connected via PCIe as my boot disk (name: Server OS). The other four drives are in a software RAID 10 (name: Server RAID, set up by disk utility). Some time recently (within the last month, I believe, but I am not positive), I lost the ability to search for files on the Server RAID disk.

Basically, whenever I search within folders in the disk, I get this searching icon: Searching But the window looks like this forever, and the search never turns up a single match. Something else I noticed is that anything that is on this disk and is tagged (using the color labels built in to macOS) does NOT turn up when I sort by the tagged colors in Finder. When I run this task in automator:automator I get this error:error

Other tidbits: I am the only user and administrator of this computer. I have tried rebooting it and reinstalling macOS. I HAVE tried getting spotlight to reindex* (see note at bottom) but without success. Recently, I have (relatively recently) made the following changes to my system:

  1. Updated macOS from 10.12.3
  2. Added website hosting using macOS Server (it's currently only hosting a test website, so it's only accessible via IP, not domain, so it should not be receiving any traffic).

*Note regarding reindexing of Spotlight: To reindex Spotlight, I went to System Preferences -> Spotlight -> Privacy. I added the Server RAID disk to the list of things for spotlight to ignore, then quit System Preferences. I reopened System Preferences, and did the same thing in reverse. I monitored my CPU usage for about 3 minutes afterwards, and it didn't increase, making me think that spotlight actually DIDN'T reindex.

QUESTION:
Can someone please explain why this might be happening and how to fix it?

0

Finally, an answer! I contacted Apple Support with the problem soon after I made this post. Two weeks and many hours of phone and chat support later, we seem to have found an answer. The problem appears to have been with the indexing at the root level (which is why reindexing from System Preferences didn't work), likely caused by the macOS 10.12.4 software update. The solution was simple:

  1. Disable all backups (Time Machine, Carbon Copy Cloner, or similar)
  2. Open the terminal app and execute these three commands in this order:

    sudo mdutil -i off /Volumes/Server\ RAID/
    sudo mdutil -E /Volumes/Server\ RAID/
    sudo mdutil -i on /Volumes/Server\ RAID/

Following this, the mds and mdworker processes get right to work reindexing (spotlight shows reindexing progress).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .