Since upgrading to Sierra (but could be other cause), my mouse slows down in certain points (as if something is intercepting the mouse move event and swallowing it). Sometimes this is accompanied by mouse cursor blinking between rapidly between different cursor shape, in a certain point which allows drag&drop (only/especially when drag is started); then the mouse pointer becomes "stuck" as if moving in dense syrup, for a few seconds/pixels. But this happens as well when not drag&dropping as well. Though, the effect is weaker (though still negatively affects productivity).

An extreme case is when doing native HTML5 drag in Chrome...

Please note: this is not about scrolling (unlike some questions which seem similar).

MacBook Pro Retina 13", late 2013. Two external DisplayPort monitors.

If this could be blamed on an app (as opposed to macOS sierra itself), then which kinds of apps would have such power to intercept and affect mouse-move events? Personally in my multiple decades of computing, I've never seen mouse-move being affected in such a way. Usually the mouse was moving the way it should...

Tried Safe Mode (holding shift while booting), but it completely fails to load (progress bar stuck at 100%)...

Time for a new macbook? Or time to go to Windows? :)

This is ruining my productivity (mouse moving at random speeds, sometimes 2-10 times slower).

Thanks for any hints! Does affect magic mouse 2 and logitech usb-cable mouse.

Problem does not seem to happen on MacBook's touchpad.

  • Right now what happened is that logitech usb-cable mouse is not affected at all, while magic mouse 2 is heavily affected. This happened after terminating karabiner grabber process. Not sure if related or just coincidence. The problem is quite random, thus perhaps Karabiner had nothing to do with it...
    – KarolDepka
    Apr 30, 2017 at 0:02
  • 2
    I've just posted an answer. However, as an aside, since you've stated both here and in your other question that you can't boot into Safe Mode, I really think you should search for answers to that, and if you can't find one, ask another question relating to it. Being able to boot into Safe Mode is a key troubleshooting step, and it would be handy for both your questions.
    – Monomeeth
    Apr 30, 2017 at 0:51
  • Good point. Upvoted. I just fear another rabbit hole. I recently had waaay too many rabit hole/ troubleshootings. Fearing that getting safe mode to work could turn into another "research project" of its own. Especially that I had problems with filesystem corruption which was somehow related to FileFault, requiring de-encrypting (no one found the real root cause, including apple-authorized tech support; just workaround; decrypting and re encrypting which then makes the problem reappear anyway). And the rabbit hole goes on and on. I hope you understand, I'm a bit tired of rabbit holes :).
    – KarolDepka
    Apr 30, 2017 at 2:34
  • I'm also thinking of getting a new macbook pro retina. Which would give me fresh install, fresh FS, etc. But then who knows what problems will appear there. Optimism bias could mean tens of hours spent instead of saved :D.
    – KarolDepka
    Apr 30, 2017 at 2:35
  • Asked about the safe mode problem: apple.stackexchange.com/questions/282315/…
    – KarolDepka
    Apr 30, 2017 at 2:40

6 Answers 6


I just found this because I had the same problem. I noticed that the cursor would come to a crawl whenever I hovered across a list of links on a website. The culprit: I had my mouse cursor set to a larger size.

Solution: Go to System Preferences › Accessibility › Display, and set the cursor size to Normal (all the way to the left). After restarting Safari, the problem was gone. I can move across a list of links, the cursor switches between arrow and hand, without lag.

  • I joined the site just to upvote this. I think it would be instructive to know how you found this out.
    – Roy Falk
    Feb 13, 2018 at 11:10
  • @RoyFalk I have a friend with the exact same MacBook Pro as me. He considered buying the same external display that I have, so he came over to try it out. He used his MacBook Pro with my Display, and we were surprised to find that the problem didn't occur. I then checked which settings were different on his one, and after a lot of searching I found that it was the cursor size. Fun sidenote: If menus fade out in a jerking way on your external display, that's because you have "Reduced Transparency" or "Increase Contrast" set to On in your System Preferences ;-) Oh Apple.
    – basteln
    Feb 15, 2018 at 14:28
  • 2
    Since I've increased the cursor size I've noticed the exact same issue e.g. using iTunes search field. It's a Sierra bug. It's not related to your mouse or external monitor. Pram, smc or booting in safe mode doesn't work. Simply change the cursor size back to normal. I am going to open a Apple bug report.
    – user136834
    Mar 3, 2018 at 22:37
  • Crazy that this would cause such a weird issue. Is it because the pointer changes size? I also had this problem, but thought it was some kind of feature at first -- to assist with honing in on links.
    – lericson
    Nov 5, 2018 at 12:29
  • Wow. I've had this problem in Stata and nowhere else. When the cursor would pass over the "Command" section of the Main Window the cursor would slow to a crawl and very rapidly link between the curly I-beam and a black pointer. I thought it might be due to the fact that I had increased my mouse tracking speed via defaults write -g com.apple.mouse.scaling 25.0, but this fixed it. Thanks. Mar 30, 2020 at 0:07

For me, removing all type-c charging cables works.


Since you can't seem to boot into Safe Mode, I would try either (or both) resetting the NVRAM and trashing the Magic Mouse .plist files.

Resetting the NVRAM

Your Mac uses Non-Volatile Random-Access Memory (NVRAM).

Here’s how to rest it on your model MBP:

  1. Shut down your machine. Yes, a full shut down, not just logging out.
  2. Press the power button and then press the commandoptionpr keys. You have to make sure you press these keys before the gray screen appears or it won’t work.
  3. Hold those keys down until your Mac reboots again and you here the startup chime.
  4. Let go of the keys and let your Mac reboot normally.

Note: When you log back in you may need to readjust some of your system preferences (e.g. speaker volume, screen resolution, startup disk selection, time zone information, etc).

Trash Magic Mouse .plist files

Since your issue persists both in and out of Safe Mode, I would trash the relevant Magic Mouse preference files.

As you don't specify what version of macOS you're using, I'll assume you're running a version from Mountain Lion and above. Follow these steps:

  1. Go to Finder
  2. Press and hold the option key
  3. While keeping the option key down, click on the Go menu and select Library from the list
  4. This should open up your user's Library folder in a new Finder window
  5. Locate and open the Preferences folder (it's within the Library folder)
  6. Within this folder find the following two .plist files:
    • com.apple.AppleMultitouchMouse.plist
    • com.apple.driver.AppleBluetoothMultitouch.mouse.plist
  7. Now Trash these files
  8. Restart your Mac

Your Mac will now create a new set of default preference files for your Magic Mouse.

Note: You will need to go back to System Preferences and reconfigure your Magic Mouse settings. However, before doing that I would test the Magic Mouse first to see if the problem behaviour still persists.

[EDIT - following successful Safe Mode boot]

Since you've now been able to boot into Safe Mode and the problem wasn't present, the first thing to do is to startup normally and see if the problem is still there. Sometimes just the act of booting into Safe Mode will resolve the issue.

If the problem is still there, the first thing I'd check is your login items. Login items can be incompatible sometimes with other software/hardware.

To do this:

  1. Go to Apple > System Preferences
  2. Click on Users & Groups
  3. In the lefthand pane, select your user name
  4. Now select the Login Items tab (near top right)
  5. Take a screenshot of the list that appears (ShiftCommand4 and select the list with your mouse cursor) or just write down the list
  6. Now click on the first item in the list so it's highlighted (i.e. click on the name, not the checkbox)
  7. Press and hold the Shift key while you click on the last item in the list
  8. All items should be selected now.
  9. Let go of the Shift key
  10. Click on the minus - button (at the bottom) to remove all items
  11. Exit System Preferences
  12. Restart your Mac

Once your Mac has booted up, test to see if your mouse is now working properly:

  • If your mouse works fine, then start to add the items back one by one (using your list or screenshot). However, only add one item at a time and restart your Mac after each one. This process will help you identify which item was causing your mouse problems. Once you know which item it is, then remove that again from your Login Items.
  • If your mouse doesn't work fine, let us know.
  • Thanks. I will try that soon. Regarding safe mode, I did not manage to enter it (hangs before logging in)! In general: do you have an idea what the real root cause could be?
    – KarolDepka
    Apr 30, 2017 at 1:31
  • 1
    Since I'm quite caucious about doing stuff like resetting nvram or deleting plist file: I would like to ask you: what leads you to believe that the mouse slowing down has something to do with nvram or plist files? Instead of e.g. some faulty app or driver messing up input events? Meaning I gotta be sure that it's worth the hassle and the risk, so as not to mess it up even worse :D! Thanks!
    – KarolDepka
    Apr 30, 2017 at 1:44
  • 3
    You don't need to do both - do one and if that doesn't resolve your issue, then try the other. Resetting the NVRAM is no big deal - it's a troubleshooting step that's been used on Macs for decades. In terms of trashing the .plist files, you can make a copy of them first and replace them again later if you're concerned. As for why I'm suggesting these courses of action, well, troubleshooting is a process of elimination, so we need to start somewhere. Since you can't boot into Safe Mode, this is just where I'm suggesting you start. Otherwise my first step would be Safe Mode.
    – Monomeeth
    Apr 30, 2017 at 1:57
  • Thanks. Great explanation! Upvoted. Given the elimination approach, I sense that we don't [yet] have any hints regarding the possible real root cause(s), right? Will try your approaches soon.
    – KarolDepka
    Apr 30, 2017 at 2:30
  • By the way, if you do reset the NVRAM this may also help with your other question (re: LG monitor issue).
    – Monomeeth
    Apr 30, 2017 at 5:29

I had the same issue and rebooted my computer which did not help.

It turned out when I turned off my Thunderbird email application, the sticking went.

So it appears this is what is causing the issue.

My Thunderbird email application has over 20,000 messages so it may be causing a memory issue.

So turn off applications to try and identify the application.

Hope this helps you.


I've been having the same problem for a while now. I've tried different mice, bluetooth and dongle, changing batteries, using a wired mouse, etc. After each change it seemed to get marginally better for a little while and then went back to awful. Moving the cursor by using the track pad sometimes seemed to unstick it, but that is not a viable option -- that's why I'm using a mouse. Last night the wired mouse seemed to be the solution, and today the problem was back.

Google searching lead me to this page so I tried the "reset the cursor size to default" trick, while I have this web page open. I had a difficult time getting the mouse to go down to the Settings icon in the Dock to make the change, it kept sticking.

I searched Settings for "Cursor", opened Accessibility, again with more sticking, made the change, and instantly my mouse started behaving properly. Not a single glitch in now almost 10 minutes of testing, where previously it was glitching every few seconds.

I really don't like the default, tiny cursor on my large monitor, but at least the Shake Mouse option still works to help me find it on the screen.

Thanks for your help in getting me unstuck. Maybe I don't need to retire my bluetooth mouse.


This started happening to me yesterday with my mouse + RF dongle.

I tried changing cursor size back to normal, moving the mouse's RF dongle to another port on the hub. No, still stuttering and dragging.

And how did I fix this? I moved the mouse dongle from the USB3 hub to a USB2 hub – problem solved!!!

(And what is strange is that the mouse dongle has been in the USB3 hub for at least 6 months without any problem, until yesterday.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .