1

A colleague has shared her Google calendar with me. It appears in Google calendar just fine. In the calendar settings I can see the iCal URL, but when I attempt to subscribe to that address in Apple Calendar, it says "A calendar wasn't found on ... Check the URL.".

I suspect this is because the calendar is shared with my via my Google account, rather than been made public. Is there anyway to sync the calendar with my Apple devices? Can I re-share it from my Google account so I can subscribe to it from iCloud?

I tried the syncselect option, which sounded promising, but couldn't see anything happen. I'm not sure how it would work anyway, since I can't see how it would have access to my iCloud account.

2

Inadvertently found a lovely solution:

  1. Go to System Preferences->Internet Accounts
  2. Add or select your Google account
  3. Click the checkbox next to "Calendars"

Voila, all my Google Calendar calendars appear in Apple Calendar, including the one shared with me. Didn't think there was going to be a solution to this, but so simple once you know.

2

There are two methods:

Method 1:

  1. When you open the link of the calendar shared with you. You could click the plus sign at the right corner to add it into your own google calendar. enter image description here

  2. Go to https://www.google.com/calendar/syncselect and check the calendar shared with you.

  3. Go to the Mac Calendar and you will find it in your calendar list just under your google account. Check it for display.

Method 2:

  1. As step 1 in Method 1.
  2. Go to the Google Calendar and the shared calendar appears in the "Other calendars", go to the setting of the shared calendar.
  3. Scroll down and find the "Integrate calendar->public address in iCal format" and copy the address.
  4. Open the Mac Calendar and go to "Files -> New Calendar Subscription" and paste the address into the "Calendar URL".

Hope this would work.

  • Isn't method 1 exactly what the OP has done? – Mark Dec 30 '18 at 18:51
  • Yes, as answered by him, you have to add your account in the MacOS using method 1. But you don't have to by method 2. – Song WANG Dec 30 '18 at 20:06
0

This worked partially. I found one additional step I needed to do: the account shared with me is a "delegated" account. So I had to go into Calendar Preferences, Accounts, and click on the delegates tab for my google account - and make sure the delegated accounts I want to subscribe to are checked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .