2

since yesterday my MacBook is stuck on boot after changing language in the systems control panel: Before the login I just see a circular loading indicator and my mouse cursor is stuck in the top left corner.

It seems like a service is restarting all the time since the loading indicator spins for like 10 seconds before disappearing and reappearing again.

I tried resetting the NVRAM, first aid from the disk utility and reinstalling OS X - it all fails and so I'm still stuck. I also tried running languagesetup from the single user shell but this just returns an error message saying "file or folder not found".

Im running OS X Sierra.

Hoping someone has some advice since Im fearing only formatting can rescue my MacBook.

Update (output of verbose mode):

IG: Called when FB is in a non-wake State in SetAttribute - attribute ´gnps´ (same message appears 3 times with ´gnps´ / ´par´ / ´p2l´)

After that the screen turns black and the following line repeats like describes above (turning black, lines again and so on):

IOConsoleUsers: gl0ScreenLockState 3, hs 0, bs 0, now 0, sm 0x0
  • What does a verbose boot show? (⌘V on boot) – grg Apr 29 '17 at 18:58
  • Also, try starting in safe mode (by holding Shift key at startup). I'd do verbose mode first, though, to see what it shows. – Gordon Davisson Apr 29 '17 at 19:08
  • Okay so here's what verbose mode tells me - first off: IG: Called when FB is in a non-wake State in SetAttribute - attribute ´gnps´ (same message appears 3 times with ´gnps´ / ´par´ / ´p2l´) After that the screen turns black and the following line repeats like describes above (turning black, lines again and so on): IOConsoleUsers: gl0ScreenLockState 3, hs 0, bs 0, now 0, sm 0x0 – Freddy Apr 29 '17 at 21:39
  • Did you solve this issue? I have exactly the same problem – user25 Mar 11 at 21:02

You must log in to answer this question.

Browse other questions tagged .