4

When I run Console, a lot of messages have the text <private> instead of details, even though my account is an Admin user account. Here is an example for an application I'm writing and trying to debug:

default 17:12:50.191150 -0700   CommCenter  #I CSIAppInfo.ApplicationActivationObserver: handleLSNotitifcation_sync: Application launched: <private>
default 17:12:50.311671 -0700   CommCenter  #I CSIAppInfo.ApplicationActivationObserver: handleLSNotitifcation_sync: Application exited: <private>

How can I make this stop happening, and get full information about processes?

6
sudo log config --mode "private_data:on"    

Show private messages in Console.app for Sierra

  • 1
    Is this working for you? I tried in macOS Sierra and some iOS 11 logs are still logged as <private>. I'm interested in seeing Apple's logs that do not come from my application but from Apple's frameworks such as apsd: <private>: Received message for enabled topic '<private>' onInterface: NonCellular with payload '<private>' with priority 5 for device token: NO – Jan Sep 13 '17 at 9:34
  • 1
    @Jan iOS 11 logs would be logged by your iOS device, not your Mac, so won't be affected by changing your Mac's private data setting. – grg Sep 13 '17 at 9:45
  • 2
    I see. Is there a way to achieve this on iOS (by installing e.g. a new profile)? – Jan Sep 13 '17 at 9:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .