0

I'm having a persistent issue and have tried all of the common fixes I have researched online (will list shortly). Symptoms: Command-R on boot only takes me to Internet Recovery, and a dated one at that (Lion I believe). Recovery HD still shows up on the main volume in terminal diskutil list (see below), but I can't get into it.

My setup, dual drive with SSD in main slot and HD in optibay:

  • Crucial M550 SSD 1TB with about ~720GB full ("Macbook Pro SSD") as main volume in the SATA HD slot. 80GB Win10 Bootcamp partition on the same drive.
  • Original Macbook HD installed in DVD slot. Not really relevant but this drive is partitioned into a second bootable Sierra partition and a "Media HD" drive for files. OS drive is not encrypted and the recovery partion works fine and is visible to select when booting and holding Opt key (but not Cmd-R). "Media HD" is encrypted.
  • Relevant: I first noticed the issue after I encrypted the SSD using Filevault (but it could have been before as I haven't booted into Recovery for a long time). The process completed successfully including optimization. After that I was able to wipe out an older Bootcamp partition, create a new one and installed Windows 10 successfully.

What I've tried so far:

  • Reinstalled Sierra maybe 3x in different ways, once from the Applications folder, once from the second internal volume using a bootable createinstallmedia Sierra install disc partition, and once using the recovery partition on the HD. I thought one of these options had worked a few times, but it turned out it was taking me to the Install disc recovery options. Once that disc was gone, I was back to internet recovery.
  • I tried http://musings.silvertooth.us/2016/10/recovery-partition-4-0-4/, including disabling SIP first using the terminal in recovery options from the install disk USB (I think the older Internet Recovery wouldn't work or didn't recognize the command). This exits with an error, something about "mainpartition" not defined. I can't recall exactly.
  • Lastly, I tried https://davidjb.com/blog/2016/12/creating-a-macos-recovery-partition-without-reinstalling-osx-or-re-running-your-installer/. I was able to successfully run through the entire process, but after this the problem had not changed and still goes directly to Internet Recovery upon boot with CMD-R

I have a feeling this may have something to do with the fact that I have filevault enabled already so any changes to Recovery HD are not working? I'm hoping to avoid having to decrypt, attempt fix, and encrypt again (it took a while for my encryption to complete with 720GB of data), but willing to try that if there are no other fixes. I'm also hoping to avoid a clean install. (I have external Time Machine backups but that disc is currently encrypting so I don't want to count on that until the encryption process is complete, 1.7TB so its taking a while. I also have other CCC backups that run regularly but that would involve setting up the whole system and apps from scratch if I can't depend on my Time Machine backup.)

Lastly, here is my diskutil list output:

/dev/disk0 (internal, physical):
#:                       TYPE NAME                    SIZE       IDENTIFIER
0:      GUID_partition_scheme                        *1.0 TB     disk0
1:                        EFI EFI                     209.7 MB   disk0s1
2:          Apple_CoreStorage Macbook Pro SSD         943.3 GB   disk0s2
3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
4:       Microsoft Basic Data Windows 10 SSD          80.0 GB    disk0s4

/dev/disk1 (internal, virtual):
#:                       TYPE NAME                    SIZE       IDENTIFIER
0:                  Apple_HFS Macbook Pro SSD        +942.9 GB   disk1
                              Logical Volume on disk0s2
                              79B0DCD6-ED6C-495A-B592-77010B8F5D7E
                              Unlocked Encrypted

/dev/disk2 (internal, physical):
#:                       TYPE NAME                    SIZE       IDENTIFIER
0:      GUID_partition_scheme                        *1.0 TB     disk2
1:                        EFI EFI                     209.7 MB   disk2s1
2:                  Apple_HFS Macbook Pro HD          200.0 GB   disk2s2
3:                 Apple_Boot Recovery HD             650.0 MB   disk2s3
4:          Apple_CoreStorage Media HD                799.2 GB   disk2s4
5:                 Apple_Boot Boot OS X               134.2 MB   disk2s5
  • For the heck of it last night I tried one more time to install the OS over my existing installation by using the installer from the Applications menu. No change and still took me directly to Internet Recovery. Anyone have any insights here? – SFH Apr 28 '17 at 16:43
1

From the sounds of it, you've covered all the steps related to disk issues. My guess is that the startup-disk selection settings are not being saved or read correctly from the NVRAM.

Resetting NVRAM as outlined by Apple's article How to reset NVRAM on your Mac:

On Mac computers that play a startup sound, you can release the keys after the second startup sound.

On iMac Pro, you can release the keys after the Apple logo appears and disappears for the second time.

Once that's done, give Command+R one more go. Good luck.

  • Thanks. I've since replaced the drive with another and did a clean install which works properly. So I no longer have the problem. – SFH Mar 14 '18 at 16:02
  • Eleven months is a rather long time. I'm not surprised my answer wasn't required any longer. – The_Stewart Apr 12 '18 at 9:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .