0

This question already has an answer here:

I wanted to comment my question directly in the thread Is it possible to disable spell check systemwide? , but I do not have enough reputation to comment, so I opened a new thread:

I just upgraded from El Capitan to Sierra and wanted to disable spell check as always for years now with this procedure:

sudo mv /System/Library/Services/AppleSpell.service/Contents/Resources \
        /System/Library/Services/AppleSpell.service/Contents/Resources.disabled
killall AppleSpell

Unfortunately this procedure doesn't work anymore as the Resources file does not exist anymore in System/Library/Services/AppleSpell.service/Contents

Does anybody know how to get rid of the spell check in Sierra?

marked as duplicate by Ɱark Ƭ, grg macos Nov 29 '17 at 19:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Read the top answer to that question. It provides the solution you are looking for. – Ɱark Ƭ Nov 29 '17 at 3:19
  • @Mark The top answer and all the answers to this post apple.stackexchange.com/questions/151527/… provides solution for the ones using Yosemite/Sierra, it doesn't works anymore for High Sierra, I have tried the mention steps, unfortuanetly it didn't worked. AppleSpell.service process keeps working in the background! – Sayan Nov 29 '17 at 3:52
1

You can disable the feature that automatically corrects misspellings but it still underlines misspelled words. Go to System Preferences, Keyboard and click on the Text tab. There is an option on the right to correct spelling automatically. Make sure this is not checked.

  • I tried this option but it still underlines misspelled words and the AppleSpell.service process keeps workking in the background inspite of disabling it from system preferences – Sayan Nov 29 '17 at 3:49

Not the answer you're looking for? Browse other questions tagged .