19

The control strip of my touch bar is not working anymore. Even after a full restart or start in safe mode.

There's nothing on the 'screen'. (Neither in Mac or Windows via Bootcamp) It doesn't respond to taps. In keyboard preferences the usual touchbar related properties are gone as well, as if my Mac doesn't even have a touch bar.

The Touch ID part (fingerprint) works fine though...

Any steps I can take to diagnose this?

  • Have you tried resetting the SMC? My guess is this will solve the problem – NoahL Apr 25 '17 at 22:59
  • Tom, I got the same issue. How did you fix it? – Robino Aug 23 '17 at 8:38
  • Curious as to how this ended up being resolved for you - I’m having the exact same issues – gfppaste Dec 22 '17 at 4:01
  • Did you ever get this resolved, and if yes, how? – Pete Jul 11 '18 at 9:12
  • I had this exact same problem, except that for me, it did respond to touch input. I could still press the buttons that were on the Touch Bar, but they weren't visible. Plugging the device in to charge solved the problem for me. – yottalogical Aug 28 '19 at 2:39
17

The first things I would do are resetting your NVRAM followed by resetting your SMC. If resetting these doesn't resolve it, run Apple Diagnostics.

Before doing any of the following, ensure your MBP isn't connected to any external devices (e.g. display, external hard drive, etc).

Resetting the NVRAM on Late-2016 MacBook Pro models

To reset the NVRAM on all Late-2016 MacBook Pro models (with and without Touch Bar) follow these steps:

  1. Shut down your machine. Yes, a full shut down, not just logging out.
  2. Press the power button and then immediately press the commandoptionpr keys.
  3. Keep these keys pressed down for at least 20 seconds!
  4. Let go of the keys and let your Mac reboot normally.

Note 1: When you log back in you may need to readjust some of your system preferences (e.g. speaker volume, screen resolution, startup disk selection, time zone information, etc).

Reset the SMC

Your MacBook Pro has a system management controller that can easily be reset. To do this on your particular model, follow these steps:

  1. Shut down your computer
  2. Keep the power cable plugged in.
  3. Press at the same time shiftoptioncontrol (on the left side of the built-in keyboard) and the power button
  4. Let go
  5. Turn your computer back on with the power button.

If this doesn't resolve the issue, use Apple Diagnostics to test your hardware.

Run Apple Diagnostics

Follow the steps below to run Apple Diagnostics:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the D key and keep it down until you see the Diagnostics screen appear
  4. Wait for Diagnostics to finish (this typically only takes a few minutes)
  5. Once complete, one of two things will appear on the screen:
    • a No issues found message
    • a brief description of any errors found plus further instructions
  6. If the diagnostics test does find errors, take a note of what they are

Note: If pressing and holding the D key at Step 3 doesn't work, start again at Step 1 and, at Step 3 press and hold both the OptionD keys instead. This will try and run diagnostics from the internet instead, so you will need to allow more time for it to complete.

|improve this answer|||||
  • Thanks for the suggestions. Unfortunately did not help though. (the diagnostics saying "no issues") I also got the kernel panic screen (and auto restart) like 4 times in 2 hours. :/ So yeah, guess I'll contact apple. – Tom Deleu Apr 26 '17 at 19:42
  • Good idea. I think this is going to be one for Apple to sort out. Good luck! – Monomeeth Apr 26 '17 at 20:57
  • Upgrading to High Sierra beta 10.13.4 broke the TouchBar for me, resetting NVRAM/SMC fixed it. Thanks! – admdrew Feb 1 '18 at 21:24
  • 1
    The first solution worked for me – ElliotM Sep 20 '19 at 23:17
2

The issue with the TouchBar issue is related to a grounding problem between the motherboard an the standoffs underneath it, what happens is that it grounds out from time to time depending on where you press on the back casing of the MacBook Pro 13 2016 (this is my personal issue with it). I did a Top Case replacement (everything except, logic board, TouchID, and screen) and the issue remained.

I now have to come up with another solution to figure it out but my guess or solution is to put thin round rubber dampers over the logic board screw holes then put the logic board back over them (same ones used on the strip covering the battery ribbon), poke a hole into into them an put the screws back in. This lifts the logic board slightly an keeps a shortage from occurring.

|improve this answer|||||
1

Go To System Preferences -> Keyboard -> Tick "Show Control Strip" Box -> Change Touch Bar Shows To Extended Control Strip or anything else that you like

Go To System Preferences -> Keyboard -> Tick "Show Control Strip" Box -> Change Touch Bar Shows To Extended Control Strip or anything else that you like

|improve this answer|||||
  • 2
    Hello Matt, I can't see this option in my dialog but I can see the others but can't see the Touch Bar shows option. – Israel Meshileya Dec 9 '19 at 8:35
1

I had the same issue and the only thing that worked was a factory reset. I hope that works for you too :)

|improve this answer|||||
1

I would make one backup of files and apps and settings you need or let Time Machine get a backup. Then boot to internet recovery and reinstall the same OS you have.

That runs through the needed EFI, recovery and bridge OS updates and likely will ensure the drivers you need are loaded.

|improve this answer|||||
1

In terminal type:

pkill "Touch Bar agent"

This terminates the ill-fated touch bar process, at which point your OS will restart a fresh, uncorrupted copy, restoring your crashed touch bar. In my case the soft keys were still responding but were not lit, so I couldn't see what I was pressing. I had this happen after several weeks of not restarting my MacBook Pro. None of the non-invasive solutions above worked and I didn't want to restart my MBP.

|improve this answer|||||
  • [Process-] Killing "Touch Bar agent" will force your OS to restart the touch bar process, in my case, relighting the soft keys, which turned off. This worked for me on 2019-08-29. If you're reading this in the future, hopefully Apple will have fixed their code and you won't be needing this any more, currently you do. – russian_spy Aug 30 '19 at 17:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .