34

The control strip of my touch bar is not working anymore. Even after a full restart or start in safe mode.

  • There's nothing on the Touch Bar's 'screen' (either in Mac or Windows via Bootcamp).

  • It doesn't respond to taps.

  • In keyboard Preferences the usual touch bar related properties are gone as well, as if my Mac doesn't even have a touch bar.

The Touch ID part (fingerprint) works fine though...

Any steps I can take to diagnose this?

7
  • Have you tried resetting the SMC? My guess is this will solve the problem
    – NoahL
    Apr 25, 2017 at 22:59
  • Tom, I got the same issue. How did you fix it?
    – Robino
    Aug 23, 2017 at 8:38
  • Curious as to how this ended up being resolved for you - I’m having the exact same issues
    – gfppaste
    Dec 22, 2017 at 4:01
  • Did you ever get this resolved, and if yes, how?
    – Pete
    Jul 11, 2018 at 9:12
  • I had this exact same problem, except that for me, it did respond to touch input. I could still press the buttons that were on the Touch Bar, but they weren't visible. Plugging the device in to charge solved the problem for me. Aug 28, 2019 at 2:39

7 Answers 7

30

The first things I would do are resetting your NVRAM followed by resetting your SMC. If resetting these doesn't resolve it, run Apple Diagnostics.

Before doing any of the following, ensure your MBP isn't connected to any external devices (e.g. display, external hard drive, etc).

Resetting the NVRAM on Late-2016 MacBook Pro models

To reset the NVRAM on all Late-2016 MacBook Pro models (with and without Touch Bar) follow these steps:

  1. Shut down your machine. Yes, a full shut down, not just logging out.
  2. Press the power button and then immediately press the commandoptionpr keys.
  3. Keep these keys pressed down for at least 20 seconds!
  4. Let go of the keys and let your Mac reboot normally.

Note 1: When you log back in you may need to readjust some of your system preferences (e.g. speaker volume, screen resolution, startup disk selection, time zone information, etc).

Reset the SMC

Your MacBook Pro has a system management controller that can easily be reset. To do this on your particular model, follow these steps:

  1. Shut down your computer
  2. Keep the power cable plugged in.
  3. Press at the same time shiftoptioncontrol (on the left side of the built-in keyboard) and the power button
  4. Let go
  5. Turn your computer back on with the power button.

If this doesn't resolve the issue, use Apple Diagnostics to test your hardware.

Run Apple Diagnostics

Follow the steps below to run Apple Diagnostics:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the D key and keep it down until you see the Diagnostics screen appear
  4. Wait for Diagnostics to finish (this typically only takes a few minutes)
  5. Once complete, one of two things will appear on the screen:
    • a No issues found message
    • a brief description of any errors found plus further instructions
  6. If the diagnostics test does find errors, take a note of what they are

Note: If pressing and holding the D key at Step 3 doesn't work, start again at Step 1 and, at Step 3 press and hold both the OptionD keys instead. This will try and run diagnostics from the internet instead, so you will need to allow more time for it to complete.

2
  • 2
    Try killall ControlStrip in terminal.
    – digout
    May 19, 2021 at 12:27
  • @digout Your comment would be better as a separate answer; see my comment below
    – David J.
    Aug 21, 2021 at 14:20
9

Go To System Preferences -> Keyboard -> Tick "Show Control Strip" Box -> Change Touch Bar Shows To Extended Control Strip or anything else that you like

Go To System Preferences -> Keyboard -> Tick "Show Control Strip" Box -> Change Touch Bar Shows To Extended Control Strip or anything else that you like

4
  • 13
    Hello Matt, I can't see this option in my dialog but I can see the others but can't see the Touch Bar shows option. Dec 9, 2019 at 8:35
  • I have the same issue @IsraelMeshileya. Did you get it working again? Nov 9, 2020 at 12:00
  • 3
    killall ControlStrip
    – digout
    Jun 2, 2021 at 9:06
  • 2
    @digout First, this might help someone in some kind of related situation, but your comment is short and doesn't give context as to the exact problem it is solving. The OP mentions the problem survives a reboot, for example. So it is unlikely that killall will solve the question. Second, as a guiding principle, it is preferable not to ask people to just "try" typing various commands in their terminal without explaining what it will do. Third, your comment would be better as a separate answer. In so doing, you have plenty of space to explain, get votes, allow edits, and invite comments.
    – David J.
    Aug 21, 2021 at 14:14
9

In terminal type:

sudo pkill TouchBarServer

This terminates the ill-fated touch bar process, at which point your OS will restart a fresh, uncorrupted copy, restoring your crashed touch bar. In my case the soft keys were still responding but were not lit, so I couldn't see what I was pressing. I had this happen after several weeks of not restarting my MacBook Pro. None of the non-invasive solutions above worked and I didn't want to restart my MBP.

If that doesn't work for you, you can also try opening the Activity Monitor and stopping TouchBarServer

3
  • [Process-] Killing "Touch Bar agent" will force your OS to restart the touch bar process, in my case, relighting the soft keys, which turned off. This worked for me on 2019-08-29. If you're reading this in the future, hopefully Apple will have fixed their code and you won't be needing this any more, currently you do. Aug 30, 2019 at 17:21
  • 5
    This worked except for it was sudo pkill TouchBarServer
    – madav
    Oct 25, 2020 at 20:07
  • 1
    No effect, and the "control strip" option is missing from System Preferences > Keyboard also. Proceeding with NVRAM reset.
    – Ed Randall
    Jan 28, 2021 at 8:44
3

The issue with the TouchBar issue is related to a grounding problem between the motherboard an the standoffs underneath it, what happens is that it grounds out from time to time depending on where you press on the back casing of the MacBook Pro 13 2016 (this is my personal issue with it). I did a Top Case replacement (everything except, logic board, TouchID, and screen) and the issue remained.

I now have to come up with another solution to figure it out but my guess or solution is to put thin round rubber dampers over the logic board screw holes then put the logic board back over them (same ones used on the strip covering the battery ribbon), poke a hole into into them an put the screws back in. This lifts the logic board slightly an keeps a shortage from occurring.

1
  • This was quite insightful, I think I'm having a similar issue, my touchbar was working perfectly fine but I cut part of the cable during a keyboard replacement so I ordered a new touchbar flex cable and now it's dead and shows no options in mac os despite it being connected with a brand new flex cable. Just curious, do you have any updates on this? Nov 9, 2020 at 12:00
1

I had the same issue and the only thing that worked was a factory reset. I hope that works for you too :)

1
  • First, the term "factory reset" does not mean the same thing across various online resources. Second, the factory reset process can vary across Macs of different models. So I would request that you (a) describe your Mac model and year; (b) give a summary of you did (startup keypresses, and so on); and (c) linked to an official Apple page if possible. Part (a) gives context; (b) guards against link rot; part (c) provides more detail if the reader needs it.
    – David J.
    Aug 21, 2021 at 14:10
1

I would make one backup of files and apps and settings you need or let Time Machine get a backup. Then boot to internet recovery and reinstall the same OS you have.

That runs through the needed EFI, recovery and bridge OS updates and likely will ensure the drivers you need are loaded.

You can revive or restore your Mac as well if you want to control that explicitly. Make sure you have a complete backup, since you may erase everything based on which path you choose.

0

A force restart (press and hold power button until the computer shuts down) did solve the problem for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .