21

I’m unable to use Siri on my MacBook Pro with macOS Siera 10.12.4. It says that there is some “Siri Audio Problem.” The issue goes away when I restart my Mac, only to return after a very short time.

I have Dictation off.

Here is what it looks like:

enter image description here enter image description here

5
  • Have you tested your microphone? Does it work on Skype (or similar)? Can you record sound? Have you tried an external mic? This will help you determine if this is a hardware or a software issue.
    – Allan
    Commented Apr 25, 2017 at 15:17
  • I did not use external mic. On first screen, "input level" indicates that mic works fine. I suggest software issue because system reboot solves problem for a short time
    – atomAltera
    Commented Apr 26, 2017 at 7:00
  • I have exactly the same issue. Cannot use Siri at all on my MacBook Pro - fine on my desktop iMac. I have Skype and Slack installed on the MacBook, and they work fine. I can also answer phone calls from my iPhone with the MacBook, so no problems with the microphone there, at all. Except for Siri, who seems to be deaf.
    – Lux Logica
    Commented Jul 12, 2017 at 4:11
  • Here's the eternal question - have you tried rebooting your computer? Commented Jul 12, 2017 at 4:23
  • @Jackson1442, yes, I tried, and after reboot it worked fine for some time. Now I don't use Siri. No Siri - no problems :)
    – atomAltera
    Commented Jul 12, 2017 at 8:31

1 Answer 1

34

I encountered that bug again and solved it with the following Terminal command:

sudo kill -9 `ps ax|grep 'coreaudio[a-z]' | awk '{print $1}'`

Within 5 secs Siri works, no need to log out / reboot.

Can somebody please check whether this solution works for you as well or not. And maybe someone can come up with a clue of what to do with audio drivers to stop this from happening in the future?

6
  • 3
    Yep, I had exactly the same issue, Siri just wasn't responding. Ran this and it worked.
    – James
    Commented Jan 14, 2018 at 19:39
  • 4
    It worked for me too, High Sierra 10.13.3.
    – arcdale
    Commented Jan 30, 2018 at 15:48
  • Just as a tangential note, after using the sudo command (above), if you are running something like Dragon for Mac (v6), this will appear to turn off the mic to that program. Simply quit out of that program and restart the program.
    – JuBe
    Commented Feb 4, 2018 at 21:18
  • Also it is helping when siri hangs Commented May 24, 2018 at 14:46
  • 1
    Worked on macOS Mojave 10.14.1.
    – SomeDude
    Commented Nov 7, 2018 at 16:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .