1

I'm trying to run a backup from one HDD to another at 10pm everynight on a Mac Pro. I have tested the rsync and it backups just fine outside of the cron table. Here is what I have and it's not running

* 20 * * * rsync -av /Volumes/HDD1/* /Volumes/HDDbackup/

This is on a Mac Pro that doesn't get turned off nightly

  • What are your sleep settings? – fd0 Apr 25 '17 at 10:06
  • Computer is set to never and display is set to 1 hour. – Andre Hopkins Apr 25 '17 at 15:42
  • OK, it's not a sleep issue. My best guess is the hard drives are not mounted when cron runs. – fd0 Apr 25 '17 at 16:13
  • Further research has revealed that the user does manually lock their PC at the end of the day. However, the system is still not set to sleep. – Andre Hopkins Apr 27 '17 at 3:26
1

Assuming that /Volumes/HDD1 and /Volumes/HDDbackup are internal drives then your crontab should be:

00 22 * * * rsync -av /Volumes/HDD1/ /Volumes/HDDbackup

If one or both drives are external drives then you need to keep the external drives mounted when the user logs out. Keep in mind that macOS usually mounts external drives as noowners (set to ignore permission). You should consider enabling permissions on any external drive with the proper access for that user.

Then set the preference file-/Library/Preferences/SystemConfiguration/autodiskmount :

sudo defaults write /Library/Preferences/SystemConfiguration/autodiskmount AutomountDisksWithoutUserLogin -bool true

Note: I didn't test whether this preference file works in Sierra.

1

Use 00 22 * * * rsync -av /Volumes/HDD1/* /Volumes/HDDbackup/ (instead of 20 - which is 8 pm!) and it will run - set up with the proper user and proper disk permissions.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .