8

I installed Wine using the .pkg from their website (installing the necessary dependencies like XQuartz beforehand). I was able to run the installer of the Windows app with no problem, but when I try to run the app itself I get:

err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.

Some googling around suggested that this might be due to not having Samba installed on my system. I installed it and started the Samba server, but I still get the same error. Any ideas about what else I could check?

2 Answers 2

2

Apple removed Samba in Lion. You'll need to reinstall it along with all the dependencies, which you can do with SMBUp. There are some caveats to installing this such as breaking Finder's network browse — you should read the app's website first.

7
  • Unfortunately I haven't been able to get SMBUp to work. When I run it, it tells me some other Samba installation is already on my machine but the "startup scripts" are not configured. If I go ahead and tell SMBUp to install anyway, it just downloads and then just hangs on the "Preparing to install..." screen. Apr 24, 2017 at 11:19
  • The other directions I see for installing Samba are here: gist.github.com/kud/6587477. However I can't see any evidence of any Homebrew recipe called "samba" or "homebrew/boneyard/samba". Apr 24, 2017 at 11:32
  • @Matthew With regard to installing with Homebrew, you need to brew tap homebrew/boneyard first, then brew install homebrew/boneyard/samba.
    – grg
    Apr 24, 2017 at 11:34
  • Thanks. After doing this, I still get the same error (Error: No available formula with the name "homebrew/boneyard/samba"). I guess from your comment that this works for you? Apr 24, 2017 at 11:56
  • 1
    I managed to fix that error by downloading the Samba sources and building it myself. Didn't solve the problem I'm having with the app though so I'll have to investigate that further. Apr 24, 2017 at 14:47
1

I would like to answer this so any other poor and unfortunate soul that has this issue doesn't have to go on the wild goose chase I just went on.

To solve the issue of ntlm_auth was not found or is outdated, you can easily solve this issue by running the following:

sudo -H /usr/local/bin/pip3 install ntlm-auth

There it is, in all its glory.

Your path to pip/pip3 may be different.

1
  • Did this install ntlm-auth or just Python bindings?
    – unixb0y
    Mar 21, 2023 at 17:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .