2

In order to organize my workspace I arrange my fullscreen apps in appropriate order, so I know what app is on the left and on the right from my current position.

However when I start an app by clicking on a dock icon and move to the desktop, my current fullscreen window places to the first position automatically, right next after the desktop.

How can I prevent macOS from this automatic change order of windows? It's very annoying to replace them manually again and again.

1

System Preferences → Mission Control and uncheck ‘Automatically rearrange Spaces based on most recent use’.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .