I’ve recently purchased an iPad Air advertised as ‘Wifi Only’ but it has the sim card tray & antenna. I’ve got the exact same model A1475 in a different storage capacity variant side-by-side with it, the model numbers match. Both are indeed Wifi + Cellular models.

Using Apple's site https://checkcoverage.apple.com and entering the serial number to check the service and support coverage of the devices, both are shown to be 'iPad Air WiFi, Cellular'

The serial numbers on the back of the devices match the serial number in ‘Settings->General->About’ for each device respectively.

The one lacking cellular capability also lacks the following fields in the ‘About’ section: Network, Carrier, Cellular Data Number, IMEI, ICCID, MEID, Modem Firmware. It does not have ‘Cellular Data’ or ‘Carrier’ in the first category of settings either as the older iPad does either, usually 'Airplane Mode, Wi-Fi, Bluetooth, Cellular Data, Carrier'.

I've tried 2 different sim cards, both which work in my phone and other cellular iPad but there's absolutely no indication that it's been inserted or lack thereof.

Other suggestion around the web and on the Apple forums indicate to restore the iPad, users have reported only WiFi firmware is compatible and resetting network settings (I've reset the entire device), all to no avail for other users either.

Browsing other forums I’ve learnt that:

  • The software setting up the antenna may have failed during a software update therefore no longer has the cellular capability. (iPhones are not prone to this however)

  • The board within the device or certain components could have been removed in order to remove an iCloud lock that existed on the device.

I picked up both second-hand for dirt-cheap prices and the newer iPad was originally advertised as ‘WiFi only’ anyway so there’s no issue with that, I would just like to find a way to resolve the issue is possible. I’d be grateful for any suggestions.

Edit 01/06/2017 I opened up the iPad and found that a cable from the sim card tray to the motherboard where the screen ICs are connected was unplugged. When turning the iPad on, it attempts to look for a signal (shows the 5 empty circles) but then changes to the text 'iPad' but without the pop-up that reads 'No sim card inserted'. I may have damaged the cable when inserting it, it was a mission to get in, that's probably why the last person who repaired it didn't put it into place.

  • 2
    You mentioned it was advertised as wifi only and you bought it knowing it didn't have cellular capabilities. I'm not seeing the problem here.
    – fsb
    Apr 22, 2017 at 19:29
  • 1
    "iPad was originally advertised as ‘WiFi only’ anyway so there’s no issue with that", correct, but the device is a cellular model so I'm trying to determine why it does not work with a sim card. If I can do that and resolve it, I can make use of the functionality.
    – darzo27
    Apr 22, 2017 at 19:49
  • Was this device bought second hand or new?
    – tyelford
    Apr 23, 2017 at 6:11

1 Answer 1


My wife had an iPhone 4 for a long time and at one stage the iPhone fell in some water. We did all the usual tricks, turn it off, put it in rice, etc. After a few days the phone was fine and worked as normal except the wifi never worked again.

I would suspect something similar happened to this iPad. The cellular module is probably damaged, for some reason or another, and doesn't work. The seller most likely advertised it as Wifi Only so you couldn't complain back to them later.

  • So Wifi stopped responding but cellular services worked fine? Did you ever see the "No Sim Card" message on screen or the 'Cellular Data' and 'Carrier' fields in settings or did they all disappear completely?
    – darzo27
    Apr 24, 2017 at 21:07
  • I was just trying to illustrate how a component can fail but the rest of the device can keep working. If I removed the Sim I would get the no sim message and yes I had access to the cellular settings. However, in the Wifi setting for me, the slider bar to turn Wifi On / Off was greyed out and stuck in the off position.
    – tyelford
    Apr 24, 2017 at 21:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .