3

So this is very weird, but the combination ⌘1 no longer works when I am logged into my iMac as me. It doesn't matter what app I have open (Finder, Slack, and Outlook all have different things bound to that combination, for instance); nothing happens when I press the combination. Both the ⌘ key and 1 work by themselves, but not together.

Specifically, if I fire up Key Codes and check the box to include modifier key events, I see the command key go down, but nothing when I then press 1. If I press ⌘2, I see the command key go down, the 2 key go down, then the keys come up. If I hit 1 by itself, I see the keydown and keyup events. But if command is held down, the 1 key triggers no events at all.

Now, if I log into the same machine as a different user, the problem goes away. So it's something weird in my user profile, but I don't know what.

I have tried swapping keyboards in the input menu, rebooting, killing every running application I could find... none of it helped.

So any tips appreciated..

  • 1
    Have you assigned ⌘1 to any Services or Application Shortcuts under Keyboard in System Preferences? – user3439894 Apr 20 '17 at 16:27
  • Turns out it was mapped to "Show Desktop 1" in Mission Control, and for some reason that supersedes everything else, even showing up in Key Codes. I don't recall changing that, but I must have done so recently; the default is control-1 instead of command-1. If you post your comment as an answer, I"ll accept it. – Mark Reed Apr 20 '17 at 18:08
2

Check to make sure you have not assigned ⌘1 to any Services, Application Shortcuts or shortcut in other Groups under Keyboard Shortcuts in System Preferences.

Depending on the version of OS X/macOS being used:

  • System Preferences > Keyboard > Keyboard Shortcuts > ...

Or:

  • System Preferences > Keyboard > Shortcuts > ...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .