4

I am trying to enabled the Chrome policy EnableLSha1ForLocalAnchors on my Mac running Sierra and unfortunately have not had much luck! So far I have tried the following:

  1. Opened the com.Google.Chrome.manifest file
  2. Changed the code below to set the values to 1 and saved the file
  3. Restarted Chrome and confirmed that the setting is not shown as enabled when viewing chrome://policy/

What am I doing wrong? This seems very complicated compared to how it is handled through the Windows registry.

Thank you

    <dict>
        <key>pfm_description</key>
        <string></string>
        <key>pfm_name</key>
        <string>EnableSha1ForLocalAnchors</string>
        <key>pfm_targets</key>
        <array>
            <string>user-managed</string>
        </array>
        <key>pfm_title</key>
        <string></string>
        <key>pfm_type</key>
        <string>boolean</string>
    </dict>
9

Open a terminal, and run the following, then restart Chrome.

defaults write com.google.Chrome EnableSha1ForLocalAnchors -bool true
  • Welcome to Ask Different and thank you for your answer. :) Unfortunately, short answers such as this don't really provide enough detail or context to help many users. If possible, it'd be good if you could add some more info on what this terminal command actually does? It's also good to provide the command that undoes the original action in case the OP wants to revert back. Also, you may want to read How to Answer for tips on providing answers here. – Monomeeth Apr 22 '17 at 1:30
  • 2
    That answer was incredible - THANK YOU! Never knew it was possible to update a manifest file that way – AAA Apr 24 '17 at 12:50
  • @dodysw running into more issues and hoping you can help :( when I entered that comment you mention, it didn't seem to quite fix the issue I was expecting it to fix. When I went to view policies (chrome:\\policy) I got a message next to the policy that states: Expected boolean value. I tried changing it to a 1 instead and same result. Am I missing something? Also how does it know where to write the manifest changes to? Thank you!! – AAA Apr 28 '17 at 21:17
  • 1
    Figured it out: defaults write com.google.Chrome EnableSha1ForLocalAnchors -bool true thank you! – AAA May 1 '17 at 12:31
  • FWIW, -string instead of -bool seems to work to set string settings. For example: defaults write com.google.Chrome SSLVersionMin -string "tls1.1" – Joe Murray Aug 28 '18 at 20:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .