4

I ran into this weird situation.

Background: I was trying to shutdown my Mac, but the Mac was waiting on another program asking me to save the file or not. I didn't notice the prompt and closed the laptop. When I opened my Mac again, the Mac was at the same state, waiting for me to respond to the prompt. Finally, I responded to that prompt and the Mac continued to shutdown.

Issue: After restarting the laptop, there was huge slowness in "Trackpad pointer speed" and "mouse pointer speed". So, I tried to set the tracking speed to fast, but the moment I close the window, it resets to slow. See below.

I tried to delete com.apple.driver.AppleBluetoothMultitouch.trackpad.plist and com.apple.driver.AppleBluetoothMultitouch.mouse, so Mac would create a new one, if it had write permissions. The Mac created new files but the issue still persists. Same case with the case of mouse speed too.

Any help is highly appreciated.

enter image description here

  • I have the same issue, but I just shut down my iMac (macOS 10.12.4) in a regular way, after which the problem occurred. I also tried resetting the SMC and PRAM/NRAM with no luck. I did a system update the day before, and this was the first restart after the update. – Mattias Arro Apr 19 '17 at 7:36
  • @MattiasArro See my answer. HTH. – Broken Link Apr 19 '17 at 19:30
  • also having this issue; no suggestions here have worked so far – Saad May 3 '17 at 0:53
  • @SaSha Try restarting your mac bunch of times with these two options. 1. "Reopen windows when logging back in" - checked. 2. "Reopen windows when logging back in" - unchecked. HTH. – Broken Link May 3 '17 at 16:18
2

Although according to his comment it didn't help Mattias, the first thing I would try is resetting the NVRAM.

Since you don't specify what model your Mac is, I've included two different sets of instructions. Choose the one that applies.

Resetting the PRAM/NVRAM on ALL MODELS EXCEPT for Late-2016 MacBook Pro models

  1. Shut down your machine. Yes, a full shut down, not just logging out.
  2. Press the power button and then press the commandoptionpr keys. You have to make sure you press these keys before the gray screen appears or it won’t work.
  3. Hold those keys down until your Mac reboots again and you here the startup chime.
  4. Let go of the keys and let your Mac reboot normally.

Note: When you log back in you may need to readjust some of your system preferences (e.g. speaker volume, screen resolution, startup disk selection, time zone information, etc).

Resetting the NVRAM on Late-2016 MacBook Pro models

To reset the NVRAM on all Late-2016 MacBook Pro models (with and without Touch Bar) follow these steps:

  1. Shut down your machine. Yes, a full shut down, not just logging out.
  2. Press the power button and then immediately press the commandoptionpr keys.
  3. Keep these keys pressed down for at least 20 seconds!
  4. Let go of the keys and let your Mac reboot normally.

Note 1: When you log back in you may need to readjust some of your system preferences (e.g. speaker volume, screen resolution, startup disk selection, time zone information, etc).

Note 2: These steps will also work to reset the NVRAM (or PRAM) for all Macs. However, the late-2016 MBP models actually required the commandoptionpr keys to be held down for 20 seconds, while earlier Macs did not require this, but doing so does not cause any problems either.

  • 2
    This issue back again and I tried the solution you provided and it did not fix it. – Broken Link Apr 20 '17 at 17:40
1

I called up apple on this. Three things we tried.

1. Login in safe mode, change and save the track speed setting - works.

2. Create another user, change and save the track speed setting - works.

But when I login with my regular account, it does not save the preferred track speed, and resets to slow.

3. The last option we tried and worked was to re-install the OS, using Command + R at startup. This option took 30 minutes or so. But, kept all my data/preferences intact.

HTH.

I haven't tried the solution by @Monomeeth.

  • 1
    This solution temporarily fixed the problem, but it returned after a day. – Broken Link Apr 20 '17 at 17:41
  • Good grief, seriously? I was greeted with this problem just this morning. Have you managed to find a reliable solution? This other post suggests that Xcode may be the culprit. Do you have Xcode installed? apple.stackexchange.com/q/278833/25193 – TylerJames Apr 25 '17 at 15:26
  • @TylerJames See my other answer below. – Broken Link Apr 26 '17 at 3:06
0

For whatever reason, I think the issue is with this option. If you select the option, it is causing the track speed reset to slow. I did couple of shutdown/restarts without that option selected and it seem to have fixed the issue.

This may or may not be the root cause.

enter image description here

0

I had this problem but I had smoothmouse installed. Once I disabled it for mice it worked just fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .