3

Recently I tried installing Windows 10 using Boot Camp on my MacBook Pro. The initial steps went smoothly until the actual windows installation where I was unable to install Windows on Boot Camp drive. I don't recall exactly if it was a MBR/GPT or NTFS/FAT32 issue, but after formatting the drive I was able to proceed with the installation.

Now Windows 10 is installed and working as expected, and so is the Boot Camp Utility software inside Windows.

The problem is that I have lost the option to boot into macOS. After restarting the machine and holding the Option key, "Windows" is the only option I have. Even after setting the default boot option to macOS inside the Bootcamp utility and restarting the machine I am back in Windows.

I tried the Apple recovery tool by holding the CMD+R at startup and downloading it. After going to the Disk Utility section the the Macintosh HD drive is greyed out:

enter image description here

Which is solved by unlocking the drive and entering my macOS password. But after restart and going to the Disk Utility it's still greyed out.

And this is the result of running "Verify Disk" on Macintosh HD.

enter image description here

Looking at the free space on the drive it seems that the data is there.

enter image description here

Since I don't have access to an Apple Store in my area to seek support I was wondering if there's a way to repair the boot and boot into macOS without losing any of my data?

And this is the output of gpt -r show disk0 and diskutil cs list entered in Terminal:

enter image description here

UPDATE: Recently I tried decrypting Macintosh HD after unlocking from Disk Utility and nothing happened. Then I tried the same process from the command line and this is what I get:

Error: -69750: Unable to modify a FileVault context
  • Looks like your Macintosh HD is encrypted. Please add a pic of the output of gpt -r show disk0 and diskutil cs list entered in Terminal (in Recovery Mode) to your question. – klanomath Apr 20 '17 at 13:22
  • Related (check the comments): Can I enable FileVault and then partition my hard drive later? – klanomath Apr 20 '17 at 14:00
  • @klanomath thanks for your response. I've added the output from terminal to my question. – Nojan Apr 20 '17 at 15:00
  • I can't say for sure but I think it's related to FV before BC. I'd try to convert it back to an unencrypted volume, boot several times from either volume and turn on encryption again. A Time Machine backup ex ante is highly recommended! – klanomath Apr 20 '17 at 15:27
  • @klanomath Thanks! Can I just ask what FV and BC are? so I can understand what I'm doing before. – Nojan Apr 20 '17 at 21:41
1
+50

Your disk is not FileVault encrypted. It was decrypted to be resized for Windows' partition and is now attempting to background re-encrypt. FV progress is literally ---- or nothing but Conversion Status:Converting. However the extents ARE successfully encrypted and thus CS sees it as a FileVault partiton. The problem I'm almost certain is from buggy CoreStorage implementation, mainly because CoreStorage is incredibly unfinished... and the fact that BootCamp Installer likely does not know how to treat a FileVault drive that is mid-encryption... on a CoreStorage LVM partition... that it as an MBR/FAT/NTFS based loader needs to resize. I suggest you don't try to layer all these technologies on top of each other in the future. FileVault is especially hard to fix if it get's nuked mid-encryption.

Try this before attempting to go further to pull the CS partition out of FileVault.

sudo diskutil unlockVolume 09CCCB6E-6693-4EBB-AA17-D8F91A1DF5C2

use the password for the FV partition then,

sudo diskutil cs revert 09CCCB6E-6693-4EBB-AA17-D8F91A1DF5C2

to disable CS, it may take some time.

You should be able to then use standard Disk Utility tools to repair and disable FileVault. You should do this as soon as possible (even if you want to re-enable it later) as your issue is almost certainly down to encryption issues. In the future be very careful with your system in the days after you enable FileVault. It encrypts your drive in the background and sudden power losses can lose you your data.

2

If you have access to Windows only I'd suggest you to try these steps:

1) Access the run command via Win + R (I don't know how Bootcamp actually remaps Win key, alternatively just open start menu and type run).

2) Insert msconfig once inside the Run GUI.

3) Once accessed the System Configuration Utility click on the Boot tab.

4) Check the option No GUI boot and click OK.

5) Now you have to Restart and hold down Option key.

You should now see Mac OS and Recovery as boot options. Enter Recovery --> Startup Disk, now you may be able to select you default boot drive.

Now Reboot as you would normally(without pressing any key while you're doing it) and you should boot automatically inside Mac OS, from there I'd create a new Bootcamp instance.

  • Thanks, but I've seen this solution on apple forums before and it didn't work for me. – Nojan Apr 22 '17 at 6:02
  • Have you already tried with a bootable USB drive? – tatoalo Apr 22 '17 at 12:25
  • I'm not quite sure what you mean. Can you please explain further? – Nojan Apr 22 '17 at 21:16
  • 1
    Sure! You'd need a USB drive where you basically install the OS image, once you have it up and running on the USB device you can reboot your Mac (with the USB inserted in) and go into Disk Manager, select your USB drive as boot disk, run Disk Utility and try to access/repair disk. Form more information about creating a bootable drive you can have a look here. – tatoalo Apr 23 '17 at 13:37
1

It sounds like you are rebooting without selecting "reboot into MacOS" from the system tray in Windows...just a hunch

  • No I've tried that too. Selecting the "Restart in OSX" from Bootcamp utility does not help either. – Nojan Apr 18 '17 at 10:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .