I recently acquired an Apple Watch (running 2.2.2). When it synced with my iPhone 7, the Keynote app was automatically installed on it, because I have Keynote in my phone. Then a problem arose: when I tried to install an app, it did not appear on the Apple Watch. It does not appear in the Apple Watch app anywhere, but it is installed on my phone. Needless to say, I would like to be able to install the app on the watch as well.

I tried restarting, and reinstalling the app. Neither worked. The app I am trying to install is Field Day.

If I missed anything, tell me in the comments. First Ask Different post!

  • The first thing you should do is upgrade the watchOS to the latest version. Right now you're several versions behind. Have you learned how to add apps to your watch? If not, see this Apple page then edit your question letting us know if that worked or not. – fsb Apr 17 '17 at 21:06
  • @fsb I will give that a try. – Comrade SparklePony Apr 17 '17 at 21:42
  • Would also help if you told us which app you're trying to install. Not all apps install to WATCH. – user11633 Apr 17 '17 at 22:05
  • 1
    @Phong I edited. – Comrade SparklePony Apr 17 '17 at 22:10

Updating it did the trick, like @fsb suggested.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .