4

I am running Sierra 10.12.4 on a 13 inch Macbook Pro, Early 2015. I recently purchased it.. In december. Anyways, I noticed this glitching when I was looking up sprites for a game that we had to make as an assignment. What I noticed was, the check pattern on png images (if they're transparent) is really glitching.

example 1

Here you can see that its displaying some sort of weird folder icon, idk. It can change too. It goes away if i zoom in or select / highlight the picture.

If i open up another image, it displays something like this. You can see that its some sort of camera icon that it picked up.

example 2

Sometimes, when I open up my facebook, it replaces all these tiny images with my profile picture! REALLY really weird. I also noticed that the loading bar on gmail [the blue one before you open your email] glitches too as it progresses. Also the scrolling is now really really sluggish on chrome.

I tested this on Chrome Canary, Same issue.

Everything else on the machine works fine. There are no glitches. I ran firewatch, it works fine. No glitches. I tested this on Safari, No issues. I did the same thing on firefox, works perfectly. I ran Cinebench, no issues, works okay..

So, what could be the issue here? Any ideas? Chrome is really my favorite browser and I really don't wanna ditch it.

EDIT / UPDATE 15/5/2017

Okay, I know I should've updated this earlier.. but switching back to 10.12.3 fixed EVERYTHING!

  • Yow! I had the same annoying problem until a couple of hours before. Sierra is now updated to 10.12.5 and the problem seems to be gone. Can you please check and let me know? I have an appointment at the Apple store which I do not really want to go :D If it is gone for good for you too then I'll be sure that my graphic card is good. – zalambOdont May 24 '17 at 6:36
  • @zalambOdont I'm running 10.12.3 now, 10.12.4 was causing this problem for me.. Its working perfectly now. So, for now, I'd not like to upgrade to 10.12.5 even though its asking me to, My finals are coming and I have to do a lot of work. If you say its gone, can you comment after like 3 days to be absolutely sure? I am pretty sure your graphics card is okay :) – candh May 24 '17 at 18:33
3

Since you're not experiencing this issue with Safari or Firefox, the first thing I'd try is turning off hardware acceleration in Google Chrome. To do this, follow these steps:

  1. Launch Google Chrome
  2. Go to Chrome > Preferences (or just press the command, keyboard shortcut
  3. At the bottom of the page, click on Show advanced settings...
  4. Look for the System subheading in the new settings that appear
  5. Uncheck the Use hardware acceleration when available option
  6. Restart Google Chrome

Let us know how you go.

  • Thanks, That did work. Scrolling feels much more natural, and glitches are gone (for now). But one thing tho, why is that enabled in the first place. What am I giving up by disabling that option. webGL doesn't really work if I disable this option... – candh Apr 16 '17 at 10:28
  • if i visit Spider which i got from chrome experiments. It says I don't have a webGL supported browser imgur.com/yfG5wfH – candh Apr 16 '17 at 10:34
  • Well, you've answered your own What am I giving up by disabling that option question. :) If you really prefer Google Chrome to be your default browser you'll have to decide whether you want the Use hardware acceleration when available option enabled or disabled, or whether you want to get into the habit of toggling it on/off as you need. I personally keep it off unless I ever actually need it (but then again, Chrome is not my default browser). Also, I learnt many many years ago that it's good to use multiple browsers (so I use Chrome when I need to, but otherwise don't use it). – Monomeeth Apr 16 '17 at 10:39
  • 2
    Let me assure you that your assertion that Everyone else's works just fine is false. That's why I was able to answer your question so quickly - I have seen Google Chrome do this on many computers for many users. You are not alone in this. Now, in your specific case, I don't have your full MBP specs. However, what I can tell you is that your Mac has an Intel Iris Graphics 6100 GPU that uses up to 1.5 GB of your main memory for its video RAM. If your model also had a dedicated GPU than you probably wouldn't be having this issue, but your model doesn't. – Monomeeth Apr 16 '17 at 10:46
  • 1
    @Monomeeth do you have any more clues as to what's causing this? Links to other bug reports? I have the exact same issue with the same iris 6100 gpu, but outside of this stackoverflow answer, I haven't been able to track down any more information about this. Is this a Chrome issue or a hardware issue? Simply disabling hardware acceleration is not an option for me as my day job involves developing WebGL content for Chrome. – timoxley Apr 23 '17 at 11:05
0

Had a similar problem myself on Chrome using macOS Sierra. In my case although I did try some of the other fixes, which didnt work in my instance, I had recently installed a bunch of new fonts. I went into fontbook and restored the default settings and lo and behold, everything is fixed and working ok. So if you've recently updated your fonts and your getting this error, chance are that this is the fix.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .