Every now and then, my Macbook Pro running the latest macOS won't connect to my WiFi. It just keeps insisting: The Wi-Fi network "Ubiquiti UniFi" can not be joined.

This happens both at home, and work, and on other random locations. It's only occasionally, it connects just fine most of the time. But when the problem shows up, no matter how often I retry to connect, the error keeps showing up. And then later that day (like a couple of hours later) it randomly connects by itself as if nothing is wrong.

Something I noticed: normally when connecting to a WiFi, the connection thingy in the top menu bar in macOS shows an animation with the bars in the WiFi icon lighting up one after another, like this:


Now whenever this connection problem occurs, I noticed the bars do not light up. The animation doesn't happen, the entire icon just stays dim. It feels like it's not even trying to connect, but obviously that's just my interpretation from not seeing the icon animate.

Also whenever this happens and I try to connect with my phone (Android 7) or iPad (iOS 10) instead, it works fine all the time. So the WiFi access point itself is really working absolutely fine.

Also my signal isn't blocked or weak or anything, I'm literally sitting 2 meters away from the WiFi antenna, with no obstacles in between. And there's not a ton of other WiFi stations nearby that might be disturbing my channel (sometimes I see two or three other SSIDs in the list with weak signals, sometimes I see none).
And there's not a ton of devices connected to the same network either. Usually just my laptop, sometimes also my phone or iPad, maybe a phone or laptop from my wife at home or colleague at work, but that's about it.

I have even tried resetting my Mac's NVRAM and the SMC, unfortunately to no avail.

Any suggestions what the hell could be causing this, or what I could do about this?

  • Have you tried forgetting it & signing back in afresh? I had a vaguely similar experience recently & that was the fix.
    – Tetsujin
    Apr 14, 2017 at 10:03
  • @Tetsujin How do you mean forgetting? I can "forget" a wifi network in Android, not sure how to do that in macOS? What I did try though is: turn off wifi, go to Network Preferences, WiFi, Advanced, and then in the list of known WiFi networks I deleted the one that I'm currently nearby (but can't connect to). Apply, then turn WiFi back on, try to connect to that network, but no, still same problem. Or do you mean something else by forgetting it?
    – RocketNuts
    Apr 14, 2017 at 11:51
  • 1
    Monomeeth has the full clean-up below - see if that helps
    – Tetsujin
    Apr 14, 2017 at 12:14
  • @RocketNuts Did you ever solve this? I am facing the same issue, it seems to be intermittent, though mostly when I close the lid on my Macbook. By any chance was your SSID hidden? were you running 5Ghz? May 10, 2019 at 23:05
  • I did all of this in the comments and it still doesn't work. And the answers don't help :(
    – Jack'
    Apr 11, 2020 at 17:26

2 Answers 2


It happened again twice since I posted this, and I think I found something that seems to work. On the terminal, I do:

networksetup -setairportpower en0 off

networksetup -setairportpower en0 on

/System/Library/PrivateFrameworks/Apple80211.framework/Versions/A/Resources/airport --scan

(that last command shows a list of available networks with their SSID)

networksetup -setairportnetwork en0 MyWifiSSID MyWifiPassword

Both times this made my connection work again.

Haven't tried Monomeeth's solution yet, but as it involves more manual interaction and rebooting my laptop, I hope the above 'on the fly' method will suffice.

  • worked for me, this is a better solution, because directly tackles the problem, not by some tedious vague procedure. And can be easily scripted. Mar 9, 2020 at 23:14

I would totally remove your Wi-Fi service, restart, and add your Wi-Fi service back.

To do this:

  • Go to Apple > System Preferences > Network
  • Select the Wi-Fi service on the left-hand side
  • Click on the cog icon at bottom-left and select Make Service Inactive
  • Now delete the service by clicking on the minus sign (i.e. the - button) at left of the cog
  • Click on the Apply button
  • Exit Network preferences
  • Restart your MBP
  • Go to Apple > System Preferences > Network
  • Click on the plus sign (i.e. the + button) at left of the cog
  • In the pop-up window, ensure that Wi-Fi is selected from the drop-down menu
  • Click on the Create button
  • Make sure Wi-Fi is on and connected (it should remember your previous settings, but if not just re-add your Wi-Fi network again)

Let me know if this resolves the issue.

  • 1
    Hey man care to explain what exactly your answer is doing? Is it just a hard network settings reset?
    – abbood
    Jan 19, 2019 at 17:39
  • It worked for me. Life saver 8-) Sep 30, 2019 at 11:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .