1

On Safari Extension Gallery page the "Install Now" button does not appear after updated to Sierra 10.12.4. It seems that Apple's official webpage didn't recognize that I'm using Safari 10.1 (12603.1.30.0.34).

enter image description here

I searched the community and found lots of discussions of similar issue, but it seems there is no magic cure for everyone. Here is what I've done so far:

  1. I can still install and activate 3rd party Extensions directly from .safariextz file. So the "Verisign Certificate" thing is not the cause of this problem. And that "Trust" button works as expected with normal mouse click (no need to enable Keyboard navigation or something).

  2. Antivirus / CleanMyMac / MacKeeper / other 3rd. party in system proxy or firewall: NOT INSTALLED in the first place.

  3. Log in with Guest account: NOT WORKING. Safari Extension Gallery still won't recognize me.

  4. Reboot into Safe mode: NOT WORKING.

  5. Fix permission with Onyx: NOT WORKING. It doesn't seem link to any files under user home directory anyway, since the Guest account also suffer from the same problem.

  6. Delete "Safari Extension List" in Keychain Access: NOT WORKING.

  7. Remove the whole "~/Library/Safari", "~/Library/Caches" and other Safari/Web*** related .plist file in SyncedPreferences and other places: NOT WORKING.

  8. EtreCheck: Diagnostic result is pasted here: https://pastebin.com/zmUcLs2R

-- Thanks for Any Help!

Richard Liu

  • 1
    I've taken the liberty of copying your update into an ordinary Stack Exchange answer, and I'll then remove the update from the question so it better follows the asking guidelines. – D A Vincent Apr 14 '17 at 8:11
  • 1
    Richard, if you want to post the answer yourself, please do so and either notify @DAVincent or use a flag to get a moderator to clean up :-) – nohillside Apr 14 '17 at 8:49
  • Yes, what @patrix said! – D A Vincent Apr 14 '17 at 8:51
  • 1
    Doesn't matter who took the credit. As long as the problem is solved and others could find it useful to them. – RichardLiu Apr 15 '17 at 10:11
1

Problem solved. It's TripMode. Unload kernel module with:

launchctl unload /Library/LaunchDaemons/ch.tripmode.TripModeNKE.plist
  • I can't claim credit for this answer; it is really from RichardLiu. – D A Vincent Apr 14 '17 at 8:13
  • 1
    Thank you. Not fully aware of the guidelines here. My bad. – RichardLiu Apr 15 '17 at 10:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .