4

I want to disable one finger scrolling with my Magic Mouse while I click with it, because I don't like that it scrolls the content in apps if I click something. I also don't see any practical use of letting this thing enabled.

Video about my problem: https://www.youtube.com/watch?v=kqCo3mEH51A

Very important, that I want to keep the scrolling on, which I generally love, so shrinking the scroll area with MagicPrefs or disabling scrolling fully is not a good workaround for me.

Are there any tools which let me disable any scroll events during the mouse button is down?

  • 2
    I watched your video and tried replicating your issue on a number of computers, but the Magic Mouse never scrolled content while I clicked on something, so I'm not sure what's happening at your end. Have you tried using your Magic Mouse with another Mac, or testing another Magic Mouse at a retail store? Obviously you've had good play with MagicPrefs, but what else have you tried? Does the issue occur in Safe Mode? Have you tried resetting the NVRAM? – Monomeeth Apr 26 '17 at 9:37
  • Hm, haven't thought about this before: I've tried my mouse now with a new computer, and it does not do the issue there. Very strange, so it will be something software related issue... – gklka Apr 26 '17 at 9:45
  • 1
    I've just posted an answer for some steps you can try. If you have a problem performing either, let me know. – Monomeeth Apr 26 '17 at 10:08
  • On the other way: I still can scroll when I move my finger while clicking on a new computer too. Only the threshold seems to be different. I am looking for a way to totally disable the scrolling while I click. – gklka Apr 26 '17 at 12:08
  • I actually prefer the Windows mouses(not trackpads) most of the time. Just my 2 cents. – William Apr 28 '17 at 2:06
3
+50

Since we've established that your Magic Mouse doesn't have this behaviour with another computer, I'd reset your NVRAM and also do a boot into Safe Mode.

Resetting the NVRAM

Older Macs had what's called Parameter RAM (PRAM), newer Macs use Non-Volatile Random-Access Memory (NVRAM).

Since you haven't specified what model of Mac you're using, below are some generic steps that will work with all models (including all Late-2016 MacBook Pro models):

  1. Shut down your machine. Yes, a full shut down, not just logging out.
  2. Press the power button and then immediately press the commandoptionPR keys.
  3. Keep these keys pressed down for at least 20 seconds!
  4. Let go of the keys and let your Mac reboot normally.

Now test your Magic Mouse to determine if the issue is still present. If this doesn't resolve it for you, proceed to booting into Safe Mode.

Note 1: When you log back in you may need to readjust some of your system preferences (e.g. speaker volume, screen resolution, startup disk selection, time zone information, etc).

Boot into Safe Mode

Follow these steps to boot your Mac into Safe Mode:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the Shift key and keep it down
  4. Let go of the Shift key when you see the login window (NOTE: If you have FileVault enabled you may need to log in twice).
  5. Take a note of what happens (i.e. test your Magic Mouse)
  6. Now exit Safe Mode by restarting your Mac as normal
  7. Again, take a note of what happens (i.e. test your Magic Mouse)

Once you've booted into Safe Mode, let me know how you went and we'll go from there.

Trash Magic Mouse .plist files

Since your issue persists both in and out of Safe Mode, I would trash the relevant Magic Mouse preference files.

As you don't specify what version of macOS you're using, I'll assume you're running a version from Mountain Lion and above. Follow these steps:

  1. Go to Finder
  2. Press and hold the option key
  3. While keeping the option key down, click on the Go menu and select Library from the list
  4. This should open up your user's Library folder in a new Finder window
  5. Locate and open the Preferences folder (it's within the Library folder)
  6. Within this folder find the following two .plist files:
    • com.apple.AppleMultitouchMouse.plist
    • com.apple.driver.AppleBluetoothMultitouch.mouse.plist
  7. Now Trash these files
  8. Restart your Mac

Your Mac will now create a new set of default preference files for your Magic Mouse.

Note: You will need to go back to System Preferences and reconfigure your Magic Mouse settings. However, before doing that I would test the Magic Mouse first to see if the problem behaviour still persists.

Reset Bluetooth Device List and Bluetooth Controller

This is something I've had a number of users do to resolve issues with 3rd party Bluetooth devices (usually a keyboard and/or mouse, but also headphones etc).

Since you're using a genuine Apple Magic Mouse you my decide not to bother, but I think it's worth trying.

In a nutshell you need to reset both the macOS Bluetooth Device List and Bluetooth Controller. However, this will reset all connected Bluetooth devices, including your keyboard and mouse, so each Bluetooth device will need to be paired again.

I have some steps you can follow, but I strongly suggest you read all of the steps first before commencing (or perhaps print out the instructions / view them on another device).

Before starting, ensure you have the Bluetooth icon showing in the menu bar. If it is not there, open System Preferences > Bluetooth and enable the option Show Bluetooth in Menu Bar.

Also, since you're trying to resolve an issue with your Magic Mouse, you will need to use another mouse to follow these steps:

  1. Hold down both the Shift and Option keys and at the same time click on the Bluetooth icon in the menu bar. Once the menu is showing, release the keys.
  2. From the Bluetooth menu, choose Debug > Remove All Devices
  3. Hold down both the Shift and Option keys again and at the same time click on the Bluetooth icon in the menu bar.
  4. From the Bluetooth menu, choose Debug > Reset the Bluetooth Module
  5. Shutdown your Mac
  6. Ensure your Magic Mouse is fully powered off
  7. Restart your Mac
  8. On your Mac, click on the Bluetooth icon in the menu bar
  9. Select the Set Up Bluetooth Device option
  10. On the mouse, turn the power on
  11. Once the Setup Assistant finds the mouse, select it from the list and click on “Continue”.
  12. Now pair your mouse
  13. If you have any other Bluetooth devices, you can go ahead and pair them now (or you can do it later).

Let me know how you go.

  • Neither of this helped. The problem also exists with safe boot after a PRAM reset. – gklka Apr 26 '17 at 11:31
  • Okay, so this issue exists while booted into Safe Mode and also afterwards when rebooted normally. I would suggest trashing the relevant .plist files as your next step. I'll update my answer to include instructions. – Monomeeth Apr 27 '17 at 4:22
  • Thank you again for your efforts. Trashing the config files didn't help either. They seemed harmless anyway: gist.github.com/gklka/df7205b9268c75dce4486a466982f738 and gist.github.com/gklka/0432f5894431a3eb2f2b43416d03f503 – gklka Apr 27 '17 at 6:36
  • I've been thinking about this issue and the fact it still happens in Safe Mode on your Mac, but doesn't happen on the other computer. You could try resetting both the macOS Bluetooth Device List and Bluetooth Controller. However, this will reset all connected Bluetooth devices, including a keyboard, so you'd have to add them back as you use them. I will update my answer to include the steps if you decide to go ahead (it's harmless - it just means if you have heaps of Bluetooth devices you'll need to pair them again). Can't guarantee this will solve your problem, but it may do. – Monomeeth Apr 30 '17 at 22:42
  • 1
    Resetting the NVRAM fix the issue for me. Thanks a lot! – kenny Jun 27 '18 at 9:49
1

The final solution for this issue: a non-documented option of BetterTouchTool:

defaults write com.hegenberg.BetterTouchTool BTTBlockMagicMouseScrollWhenClicked YES

  • How do you implement this option? – Nicolas Hung Jan 8 at 16:57
0

This might sound like a strange solution, but you should try using your Magic Mouse on a different surface.

I recently changed my mouse mat/surface and this sort of strange Magic Mouse behaviour has all but disappeared.

My old surface was so worn/used it had started to become shiny in patches. My guess is that these shiny patches are causing the mouse to report abnormal patterns of signals, which causes all manner of strange behaviour in general use.

  • Welcome to Ask Different. In which way would this disable scrolling? Perhaps I’m missing something, though. – bmike Sep 15 '17 at 0:02
  • @bmike moving to a better surface prevented the spurious scrolling whilst clicking issue for me. My theory is that, somehow, shiny or inconsistent surfaces cause the tiny movements of the mouse that happen during a click to be reported as a scroll. You can read more about my experiences and path to the solution here: forum.affinity.serif.com/index.php?/topic/… – Matt Sephton Sep 15 '17 at 10:08
0

I found a solution to this that works for me. When I need "fine touch" while clicking, I put two fingers rather than on the mouse. The mouse is far less sensitive to scroll when it registers two fingers.

It took a small bit of getting used to this new behavior, but then there was quickly less foul language and more work done. ...and I still have the scroll feature (up-down and left-right) for browsing and reading.

You must log in to answer this question.

protected by Community Mar 5 at 17:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .