0

In website sites like Twitter & Facebook, I used to (can’t remember when things “broke”) have videos autoplay, but they no longer do. (Videos do autoplay correctly in Firefox.) I can get them to play after I double-click them, which maximizes them to full-screen. If I minimize back to a std inline video, they continue playing “correctly.” I have some extensions, but disabling them doesn’t help. Also, disabling all plugins doesn’t help. Suggestions to fix?

1

There is a hidden setting in Safari that disables auto-playback of videos.

To enable auto-playback, paste the commands below in Terminal.app (CMD+Space, type "Terminal"). Quit Safari first.

defaults write com.apple.Safari WebKitMediaPlaybackAllowsInline -bool true
defaults write com.apple.SafariTechnologyPreview WebKitMediaPlaybackAllowsInline -bool true
defaults write com.apple.Safari com.apple.Safari.ContentPageGroupIdentifier.WebKit2AllowsInlineMediaPlayback -bool true
defaults write com.apple.SafariTechnologyPreview com.apple.Safari.ContentPageGroupIdentifier.WebKit2AllowsInlineMediaPlayback -bool true

You may need to reboot your Mac.

To disable auto-playback in Safari use the commands below:

defaults write com.apple.Safari WebKitMediaPlaybackAllowsInline -bool false
defaults write com.apple.SafariTechnologyPreview WebKitMediaPlaybackAllowsInline -bool false
defaults write com.apple.Safari com.apple.Safari.ContentPageGroupIdentifier.WebKit2AllowsInlineMediaPlayback -bool false
defaults write com.apple.SafariTechnologyPreview com.apple.Safari.ContentPageGroupIdentifier.WebKit2AllowsInlineMediaPlayback -bool false

In case this should not work, please let us know if the video-playback works with the Safari Technology Preview.

  • 1
    Success! I am not using the tech preview, so only the 1st and 3rd commands in your first block are necessary. No reboot required. – Conrad Apr 11 '17 at 15:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .