0

This question already has an answer here:

e.g. cloudd wants access to icloud keychain, local items keychain etc.

I have been going nuts with this bug (it IS a bug as it seems to be caused by unhandled corruption to the icloud keychain). I've had it 3 times now and it keeps coming back.

I'm basically almost constantly bombarded with requests to provide a password for any one of several combinations of the above error (different things needed access to different keychains). When I provide my password, it either gives me an 'incorrect password' response (shaking) or accepts it then asks for it again.

I have tried to turn off iCloud, but I can't, it turns itself back on. I'm guessing this was a sync issue originally, but it's well out of hand now.

I'm using a 2015 macbook pro with 10.12.3 (Sierra).

marked as duplicate by bmike Nov 27 '18 at 22:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

https://discussions.apple.com/thread/5680074?tstart=0

I got this from an answer on the Apple.com site link (above) after about 6 hours searching and trying different solutions. It's the only one that hasn't shown at least one of those login prompts in the first 5 minutes. Thanks to 'rccatalyst' for providing it. I'm copying it here, because Apple support just hasn't worked for me. The thread linked above it 4 years old and yet it hasn't turned up in any of my FAQ/google/KB searches.

Open 'Terminal' and run the commands below.

cd ~/Library/Keychains

ls

(When you 'ls' here you will see a folder that contains a bunch of random number like so: 94ED610F-DD96-4ECF-A2BC-7D2F8653A464 (this number is unique on each system))

rm -rf 94ED610F-DD96-4ECF-A2BC-7D2F8653A464 (i.e. whatever your code is)

Now reboot your Mac.

When you log back in everything should be back to normal.

Not the answer you're looking for? Browse other questions tagged .